Author Topic: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor  (Read 34626 times)

lindapowers

  • Full Member
  • ***
  • Posts: 1335
  • If you're going through hell, keep going.
    • Los Angeles immigration lawyers
  • Skype Name: manu.gonzalez91
  • VirtueMart Version: Latest avi
It works from the backend thanks.

I updated from the frontend cause that account is fe sa vendor but I could buy an item for someone at my own shop and I will have to change the delivery adress, that will cause the bug.

Regards

Polleke

  • Beginner
  • *
  • Posts: 35
I do not understand. A vendor is a seller not a buyer (customer). But it works thats great.

tez

  • Jr. Member
  • **
  • Posts: 130
I upgraded from 2.0.8e to 2.0.20b and can't save State/Province/Region from front or backend. in Backend it says "Select an Option" as a linked text only.

lindapowers

  • Full Member
  • ***
  • Posts: 1335
  • If you're going through hell, keep going.
    • Los Angeles immigration lawyers
  • Skype Name: manu.gonzalez91
  • VirtueMart Version: Latest avi
A vendor is a person and can or should be able to buy products in his own shop lol

cpetitclerc73

  • Beginner
  • *
  • Posts: 18
    • Surf Web Design
I have the same error when updating my address in the front end. Joomla 2.5.9 Virtumart 2.0.20b

vmError: VmTable #__virtuemart_vendors_en_gb Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given

interfmtas

  • Beginner
  • *
  • Posts: 2
I'm having the same issue on here, j259 - vm2020b.
Already tried editing all the data via be, fe, directly on the database without any success.
Even cleared recreated all the users/shoppers (including the joomla admin) trying to fix this.
Itonly happens when logged in as the Vendor user.
I know its not a big deal, but i simply cant let it go.
Anyone solved this? Any hints would be great.

reivaj01

  • Beginner
  • *
  • Posts: 13
Hi,

I solved this issue, but I don't know if is the best way to do.

I think that the problem was that the vendor info don't put in the POST data (in the administrator zone, yes).

I solved this simply put this lines at the end of the template (.../user/edit_address.php), just before "echo JHTML::_('form.token');"

Code: [Select]
foreach ($this->vendor as $vendorPropiedad=>$vendorValor) {
echo '<input type="hidden" name="'.$vendorPropiedad.'" value="'.$vendorValor.'" />';
}

In this way, all the vendor info is put in the form and then is treated correctly (by POST).

If anyone try it, the test results are welcome.

Regards

Tobes

  • Beginner
  • *
  • Posts: 33
I have the same problem, I tried all the methods in this thread including updating edit_adress.php with no luck.

Any more ideas please?

Servelatin

  • Beginner
  • *
  • Posts: 6
The same problem.
All works fine, but it's not looks good for customers.

Look for this issue ( i didn't try it)
Quote
http://www.joomlahackers.net/virtuemart-tutorials/store-information-not-getting-saved-in-virtuemart.html

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2656
The same problem.
What is your problem with mentioned on forum solutions for this issue?
You can support Community by voting for Project on the JED
https://extensions.joomla.org/extension/virtuemart/#reviews
Join us at
https://twitter.com/virtuemart

bavarian1969

  • Beginner
  • *
  • Posts: 1
I had the same problem with categories:

vmError: VmTable #__virtuemart_categories_de_de Check not passed. Neither slug nor obligatory value at category_name for auto slug creation is given

Until now it seems, that this problem occurs, when the value in the field "SEF alias". This column title for this in the database is "Slug".

Since I started entering unique entries in "SEF alias" for each category, saving works fine again.

I hope, this is of any help for you out there...