VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: julianmx on October 26, 2012, 02:53:03 am

Title: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: julianmx on October 26, 2012, 02:53:03 am
that's happened when try to add a sending address

vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given

help!!!
plaese!!!
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: bytelord on October 26, 2012, 03:06:02 am
hello,

What's your joomla, VM and PHP versions?

Regards
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: julianmx on October 26, 2012, 04:11:47 am
oops sorry:

PHP Version    5.2.17
Web Server    Apache
Joomla! Version    Joomla! 2.5.7 Stable [ Ember ] 13-September-2012 14:00 GMT
VM Installed version 2.0.12e
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: julianmx on October 26, 2012, 05:16:27 am
I did the upgrade to the last version, and change the front language for english now I get this error

vmError: exeSortSearchListQuery Table 'kroacom_001.rj6ck_virtuemart_shipmentmethods_en_gb' doesn't exist SQL=SELECT SQL_CALC_FOUND_ROWS * FROM `rj6ck_virtuemart_shipmentmethods_en_gb` as l JOIN `rj6ck_virtuemart_shipmentmethods` USING (`virtuemart_shipmentmethod_id`) ORDER BY ordering DESC LIMIT 0, 10


 :-\ :-\ :-\ :-\
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: julianmx on October 26, 2012, 05:20:27 am
Forget it, sorry, my mistake,
I update the database wiyh a previous back , but the error continues,



        vmError: VmTable #__virtuemart_vendors_en_gb Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given
        vmError: vmTable loadTable 'kroacom_001.rj6ck_virtuemart_vendors_en_gb' doesn't exist SQL=SELECT `rj6ck_virtuemart_vendors_en_gb`.* ,`rj6ck_virtuemart_vendors`.* FROM `rj6ck_virtuemart_vendors_en_gb` JOIN rj6ck_virtuemart_vendors using (`virtuemart_vendor_id`) WHERE rj6ck_virtuemart_vendors_en_gb.`virtuemart_vendor_id` = "1"
        vmError: exeSortSearchListQuery Table 'kroacom_001.rj6ck_virtuemart_paymentmethods_en_gb' doesn't exist SQL=SELECT o.*, CONCAT_WS(' ',u.first_name,u.middle_name,u.last_name) AS order_name ,u.email as order_email,pm.payment_name AS payment_method FROM rj6ck_virtuemart_orders as o LEFT JOIN rj6ck_virtuemart_order_userinfos as u ON u.virtuemart_order_id = o.virtuemart_order_id AND u.address_type="BT" LEFT JOIN rj6ck_virtuemart_paymentmethods_en_gb as pm ON o.virtuemart_paymentmethod_id = pm.virtuemart_paymentmethod_id WHERE ( u.virtuemart_user_id = 42 AND o.virtuemart_vendor_id = "1" ) order by o.modified_on DESC

Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: bytelord on October 26, 2012, 09:28:14 am
Hello,

Did you back before upgrade?

Go to tools-> Tools and migration -> Install or if necessary update tables

Reagards
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: drewby07 on November 13, 2012, 18:55:44 pm
Tagging along here...just did a totally fresh install of J and vm 2.0.14 trying to resolve the errors when adding a new shipping address.  I am now able to add a new shipping address, but get this error...
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: optmax on November 14, 2012, 01:50:44 am
J! 2.5.7
PHP 5.3.10
VM 2.0.14

Add me to the list of people with this problem on add/edit ST address but with en_gb:

vmError: VmTable #__virtuemart_vendors_en_gb Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Polleke on November 14, 2012, 18:18:48 pm
Hi,
me too.
I added a new user. and the following error ouccrs.

VmTable #__virtuemart_vendors_nl_nl Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given

the table exists and there is one item in it.

regards Jan
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: colossally on November 21, 2012, 20:16:08 pm
Hi all

It's been a while since this error was first posted and it may have been resolved for most, but I had the same issue and this is how I fixed mine for those still seeking solutions.

In my billing details form, the State/Province/Region field - which is mandatory - was empty because I didn't add my states yet. Once the states were added, the error went away.

When looking at the error message, it refers to "Check not passed" which I'm guessing is the check to see if the mandatory field has been entered, in this case not.

Hope this helps someone!
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: lindapowers on November 25, 2012, 15:31:14 pm
Add me too, any solution please? tried all the mentioned here.

In my case I can update the shipping adress and info but the message always appears, not very nice for customers.

Regards
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Polleke on November 25, 2012, 16:45:13 pm
Hi,
my problem was solved after i discoverd not all the vendors properties  where filled in. After filling them it worked fine.

regards Jan
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: lindapowers on November 25, 2012, 19:09:02 pm
Hi I just noticed that vendor details are not saved, it wont apply changes, when i write all the details it will delete it again after saving.

File has permission.

Any idea?
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: lindapowers on November 25, 2012, 19:18:32 pm
Hi I just noticed that vendor details are not saved, it wont apply changes, when i write all the details it will delete it again after saving.

File has permission.

Each time I update the info for the vendor from the frontend it appears blank at the backend.

Any idea?
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Polleke on November 25, 2012, 19:25:39 pm
Well not really,
 but i updated them from the backend. Why update from the frontend? I do my admin always from the backend.
Does it work from the backend with you?

regards Jan
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: lindapowers on November 25, 2012, 20:30:48 pm
It works from the backend thanks.

I updated from the frontend cause that account is fe sa vendor but I could buy an item for someone at my own shop and I will have to change the delivery adress, that will cause the bug.

Regards
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Polleke on November 25, 2012, 20:40:31 pm
I do not understand. A vendor is a seller not a buyer (customer). But it works thats great.
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: tez on March 22, 2013, 04:10:22 am
I upgraded from 2.0.8e to 2.0.20b and can't save State/Province/Region from front or backend. in Backend it says "Select an Option" as a linked text only.
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: lindapowers on March 22, 2013, 12:02:43 pm
A vendor is a person and can or should be able to buy products in his own shop lol
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: cpetitclerc73 on April 24, 2013, 03:12:02 am
I have the same error when updating my address in the front end. Joomla 2.5.9 Virtumart 2.0.20b

vmError: VmTable #__virtuemart_vendors_en_gb Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: interfmtas on June 28, 2013, 21:19:57 pm
I'm having the same issue on here, j259 - vm2020b.
Already tried editing all the data via be, fe, directly on the database without any success.
Even cleared recreated all the users/shoppers (including the joomla admin) trying to fix this.
Itonly happens when logged in as the Vendor user.
I know its not a big deal, but i simply cant let it go.
Anyone solved this? Any hints would be great.
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: reivaj01 on July 02, 2013, 16:28:38 pm
Hi,

I solved this issue, but I don't know if is the best way to do.

I think that the problem was that the vendor info don't put in the POST data (in the administrator zone, yes).

I solved this simply put this lines at the end of the template (.../user/edit_address.php), just before "echo JHTML::_('form.token');"

Code: [Select]
foreach ($this->vendor as $vendorPropiedad=>$vendorValor) {
echo '<input type="hidden" name="'.$vendorPropiedad.'" value="'.$vendorValor.'" />';
}

In this way, all the vendor info is put in the form and then is treated correctly (by POST).

If anyone try it, the test results are welcome.

Regards
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Tobes on July 25, 2013, 21:28:18 pm
I have the same problem, I tried all the methods in this thread including updating edit_adress.php with no luck.

Any more ideas please?
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Servelatin on August 17, 2013, 09:43:25 am
The same problem.
All works fine, but it's not looks good for customers.

Look for this issue ( i didn't try it)
Quote
http://www.joomlahackers.net/virtuemart-tutorials/store-information-not-getting-saved-in-virtuemart.html
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: Maxim Pishnyak on August 18, 2013, 11:41:57 am
The same problem.
What is your problem with mentioned on forum solutions for this issue?
Title: Re: vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor
Post by: bavarian1969 on November 29, 2013, 14:27:27 pm
I had the same problem with categories:

vmError: VmTable #__virtuemart_categories_de_de Check not passed. Neither slug nor obligatory value at category_name for auto slug creation is given

Until now it seems, that this problem occurs, when the value in the field "SEF alias". This column title for this in the database is "Slug".

Since I started entering unique entries in "SEF alias" for each category, saving works fine again.

I hope, this is of any help for you out there...