Author Topic: New pre subrelease VirtueMart 2.0.3. UPDATE I  (Read 104599 times)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10094
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
New pre subrelease VirtueMart 2.0.3. UPDATE I
« on: March 14, 2012, 19:34:04 pm »
New version I

http://dev.virtuemart.net/attachments/download/409/com_virtuemart.2.0.3.I_extract_first.zip

-added
more js stuff, fixes and enhancments found in the forum.

-added
- feature for automatic costprice calculation for entered final price
- small various fixes.

Fixes:
- fixed loop for vmdebug admin only
- fatal systempay

Fixes:
- overwrites for mails work,
- rounding digits in cart
- enhanced child variants creation
- various, more description will follow
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

BaidareW

  • Jr. Member
  • **
  • Posts: 111
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #1 on: March 14, 2012, 21:29:11 pm »
After upgrade from 2.0.3b to 2.0.3c front page does not open at all :

Code: [Select]
Fatal error: Class 'plgVMPaymentPayzen' not found in /XXX/plugins/vmpayment/systempay/systempay.php on line 24
After turning off plugin systempay site loads again.

lipes

  • Full Member
  • ***
  • Posts: 720
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #2 on: March 14, 2012, 22:03:28 pm »
First impressions:
It gave me a message when i installed new version 2.0.3c

"Warning, the Safe path is empty, for safety reasons it is very important to create a folder in a path not accessible by an URL, create also a folder invoices in it to store your sensible data secure. Our suggested path is for your system D:\Ampps\www\vmfiles"
- If user create that directory he/she needs to create a blank index.html file too, right?
- I'm in a localhost ampps server... but if any user have this in a webhosting he needs to change the value of chmod too?
- Why the com_virtuemart.2.0.3.c.zip doesnt install this folder automatically (by default)?

(it's really necessary to take this action to VM2 work? My fathers invoices will be provided by a different software on their PC. We'll just use in the future the VM2 to receive costumer orders by e-mail... humm..)

and also find this things not solved yet on 2.0.3C : http://forum.virtuemart.net/index.php?topic=99052.msg329013#msg329013

PS: to test this i've add the folder "vmfiles" and also add the link in Configuration > Template > Safe Path: D:\Ampps\www\vmfiles   ... Then i saw that the VM2 create another folder called: "vmfilesinvoices" here D:\Ampps\www\vmfilesinvoices ... strange!? two folders to the same thing?!

Best regards
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #3 on: March 15, 2012, 10:23:43 am »
Hi ,
Joomla 2.5.2
Just for me - 2.0.3 c

My small cart shows the right final price .

My main shopping cart now has errors - The product is shown and is correct but now I have no - shipping cost showing, no payments,  nor a final price.( right at the bottom)

However the - invoice sent to the customer has the correct price and shipping showing.

* Just as a test I went into configuration and turned on all 'show Following prices' just to check - I still have no shipping, payments nor total in cart.

It did round a product of  $199.95 to $200.00 which is correct in Australia.
-------------------------------------------------------------------------------------------------------------------------------------------------------------
I turned on bug for administrators to find the issue ( the message appeared Fatal error) - I could not get into the back end of my site - at all .

the only way was to reinstall my whole site and data base - (very scary) - lucky I did the right thing before testing "2.0.3 c -  I then purchased the same item I did before and every thing worked well - I am back using version "b" - sorry - but I can say the rounding appeared Ok.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #4 on: March 15, 2012, 13:04:25 pm »
Just a passing thought ?

Now  some of us on the new version are getting this message:

Warning, the Safe path is empty, for safety reasons it is very important to create a folder in a path not accessible by an URL, create also a folder invoices in it to store your sensible data secure. Our suggested path is for your system .....

THis needs a clearer explaination of what to do? I have created for joomla other CMs systems ( folders) outside of the public folder for a variety of reasons - But what does this mean?

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #5 on: March 15, 2012, 14:47:57 pm »
Hi,

Quote

Fatal error: Class 'plgVMPaymentPayzen' not found in /XXX/plugins/vmpayment/systempay/systempay.php on line 24
Txs. Fixed.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28147
  • Always on vacation
    • Jenkin Hill Internet
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #6 on: March 15, 2012, 15:05:05 pm »
@John2400 that is to stop people getting this error message: http://forum.virtuemart.net/index.php?topic=98633.0

Not very good English, though......
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.24 PHP 7.4.14

antonino78

  • Jr. Member
  • **
  • Posts: 130
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #7 on: March 15, 2012, 15:56:09 pm »
I have installed: VirtueMart 2.0.3. C
but from the front end I get this error: Fatal error: Class 'plgVMPaymentPayzen' not found in root\mysite\plugins\vmpayment\systempay\systempay.php on line 24
how can I fix this?

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
Re: New pre subrelease VirtueMart 2.0.3. C
« Reply #8 on: March 15, 2012, 16:04:27 pm »
Hi

Turn off the plugin systempay.

lipes

  • Full Member
  • ***
  • Posts: 720
Re: New pre subrelease VirtueMart 2.0.3. D
« Reply #9 on: March 15, 2012, 20:35:11 pm »
Joomla Error Reporting Turned ON (Development) i cant see this lines:
Code: [Select]
Strict Standards: Non-static method VmConfig::loadConfig() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\admin.virtuemart.php on line 37
Strict Standards: Non-static method VmConfig::setStartTime() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 183
Strict Standards: Non-static method Permissions::getInstance() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 537
Strict Standards: Non-static method VmConfig::get() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\permissions.php on line 153
Strict Standards: Non-static method VmConfig::setdbLanguageTag() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 407
Strict Standards: Non-static method VmConfig::showDebug() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 132
Strict Standards: Non-static method VmConfig::get() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 259
Strict Standards: Non-static method Permissions::getInstance() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 266
Strict Standards: Non-static method Permissions::getInstance() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 537
Strict Standards: Non-static method VmConfig::showDebug() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 132
Strict Standards: Non-static method VmConfig::get() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\admin.virtuemart.php on line 38
Strict Standards: Non-static method vmJsApi::jQuery() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\admin.virtuemart.php on line 44
Strict Standards: Non-static method VmConfig::get() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 802
Strict Standards: Non-static method VmConfig::get() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 807
Strict Standards: Non-static method vmJsApi::jSite() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\admin.virtuemart.php on line 45
Strict Standards: Non-static method VmConfig::get() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\config.php on line 860
Strict Standards: Non-static method Permissions::getInstance() should not be called statically in D:\Ampps\www\mp5\administrator\components\com_virtuemart\admin.virtuemart.php on line 49
Strict Standards: Non-static method AdminUIHelper::startAdminArea() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\views\virtuemart\tmpl\default.php on line 23
Strict Standards: Non-static method AdminUIHelper::buildTabs() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\views\virtuemart\tmpl\default.php on line 29
Strict Standards: Non-static method AdminUIHelper::showAdminMenu() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\adminui.php on line 94
Strict Standards: Non-static method AdminUIHelper::_getAdminMenu() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\adminui.php on line 221
Strict Standards: Non-static method AdminUIHelper::endAdminArea() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\views\virtuemart\tmpl\default.php on line 33
Strict Standards: Non-static method VmConfig::get() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\adminui.php on line 118
Strict Standards: Non-static method VmConfig::getInstalledVersion() should not be called statically, assuming $this from incompatible context in D:\Ampps\www\mp5\administrator\components\com_virtuemart\helpers\adminui.php on line 100
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

enock

  • Beginner
  • *
  • Posts: 40
Re: New pre subrelease VirtueMart 2.0.3. D - pagination still broken
« Reply #10 on: March 15, 2012, 22:56:32 pm »
J2.5.3 VM 2.0.3D

Leave a category on page 6 and enter new category on page 6 - SHOULD BE 1

Can we have a routine that asks in a Catery id is not equal to the present id the pagination is set to 1?

:(

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: New pre subrelease VirtueMart 2.0.3. D
« Reply #11 on: March 16, 2012, 09:53:55 am »
Updated to 2.0.3 d version -
Joomla 2.5.2
PHP. 5.2.9
Every thing works well - rounding off ok   But: But -- I still have the error in the main cart as described below

My main shopping cart now has errors - The product is shown and the price is correctly displayed  but now I have no - shipping cost showing, no payments,  nor a final price.( right at the bottom)
However the - invoice sent to the customer has the correct price and shipping showing.
* Just as a test I went into configuration and turned on all 'show Following prices' just to check - I still have no shipping, payments nor total in cart.


* remember I tested this product in version b and it worked perfectly - in the main cart - ? so must be the update.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10094
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New pre subrelease VirtueMart 2.0.3. D
« Reply #12 on: March 16, 2012, 12:49:00 pm »
Yepp John, I found the problem for this.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

TBoele

  • Beginner
  • *
  • Posts: 33
Re: New pre subrelease VirtueMart 2.0.3. D
« Reply #13 on: March 16, 2012, 16:39:17 pm »
When are the stockable customfields being fixed ?
And the Notify me button ?

These bugs are there for a long time.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10094
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New pre subrelease VirtueMart 2.0.3. D
« Reply #14 on: March 16, 2012, 17:19:38 pm »
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/