“getProductPrices no object given query time” in home after upgrade to 2.0.8a

Started by Federico, July 03, 2012, 15:39:25 PM

Previous topic - Next topic


After upgrading to 2.0.8a it appears in home page the following:

getProductPrices no object given query time

Someone knows this problem and how to solve it?


i have the same problem!!

In backend in products details the same error message and NO PRICE is shown at the appropriate field..

In frontend no prices at alla and an error message per product (e.g. in category view)

the error message:

vmError: getProductPrices no object given query time

using vm 2.0.8c


Everything was fine with version 2.0.6, but after upgrading to 2.0.8c I had the same problem, but I also had another message described in the topic http://forum.virtuemart.net/index.php?topic=104887.0

I found a solution how to remove the "Info" warnings, and the result showed that the error message "getProductPrices no object given query time" is also gone.


I am running a smart addons module called "Sj Vm Extra Slider" which when turned off completely removed this error.

Some one else having a similar issue here


I got also error messages after upgrade from 2.0.6 to 2.0.8e
When trying to add some products to shopping cart following error messages will appear:

"Error the quantity of the product for calculation is 0, please notify the shopowner, the product id 0"

In my test computer version 2.0.8e shopping cart works fine but when updated my live site I got same error message with every product what I tried to add my cart.