Author Topic: vm118-USPSv5.2011.03.25 Notice: We are unable to ship via USPS at this time.  (Read 3112 times)

volksman3

  • Jr. Member
  • **
  • Posts: 91
    • Akira Studio
Hi

I am having some troubles with the USPS modification version 5.2011.03.25 on Joomla 1.5.23 and Virtuemart 1.1.9

I have this working fine on my dev site but now i have moved the site to a new server running the same version of php the USPS code is returning Notice: We are unable to ship via USPS at this time. System Error.

The thing is this still works fine on the old dev site but now the site has moved it does not and i have not changed a thing other than moving the site using Akeeba backup.

Does anyone have any ideas on what could be causing this as i am stumped?

The debug info i get is:
uspsv5::__construct() - Starting module version 5.2011.02.10
uspsv5::list_rates() - Starting
Shipment::addPackage() Adding a new bundled package
Shipment::addPackage() - Package Number: 1
Shipment::addPackage() - Package is Bundled
Shipment::addPackage() - Maxweight: 70
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::query_rates() - Querying for Source: US/ , Destination: US/06161, Weight: 3.06, Value: 29.25
uspsv5::get_rates_array() - invalid source ZIP.
Package::query_rates() - Rate query returned null results.
Shipment::populate() - query_rates() failed.
uspsv5::list_rates() - shipment->populate() failed!

But this zip code works fine on the dev site.

Is there any paths coded hard coded i should know about as the only real difference is the URL of the dev site is different to the live site?

Any help would be most welcomed and i am happy to pay for a solution as i need to get the store live asap.

Thanks in advance

Regards

Tony




Parachutes are like minds, they only work when they are open!
http://www.akirastudio.co.uk

volksman3

  • Jr. Member
  • **
  • Posts: 91
    • Akira Studio
A further update on the above, i just checked the permissions of the files added by the USPS code and there were a couple of differences between the dev server and the live server so i changed those but still no effect.

The only other thing i can think if is that i am using SSL on the live site but i dont see how this could screw things up.

Very confused and no idea how to fix this.
Parachutes are like minds, they only work when they are open!
http://www.akirastudio.co.uk

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Quote
uspsv5::get_rates_array() - invalid source ZIP.

Make sure that:
1) Your store zip code is populated
2) any "override" zip code in the module config is completely blank or populated
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

volksman3

  • Jr. Member
  • **
  • Posts: 91
    • Akira Studio
Thanks so much Reggie, you are a star! - a developer friend of mine also found the fix at the same time, will send a donation for you help ;o)

I did not have a zip code defined in the edit store page as you suspected ;o)

All is working fine now  :)
Parachutes are like minds, they only work when they are open!
http://www.akirastudio.co.uk