Author Topic: Multi variant custom label number as 0 (cero), values saved but not displayed  (Read 1213 times)

razor7

  • Jr. Member
  • **
  • Posts: 355
    • MGSCreativa - Professional VM!
Hi! this is a tricky issue I guess. I have created a Multi Variant field and in my products, all have two branches, Talle (size) and Color. For Talle (size) I can set any string like Small, Medium, Large, etc, but some products have sizes in numbers starting at 0, for instance: 0, 00, 000.

For the custom label of the Talle (size) branch, I found VM to have issues with labels that only contains 0's, please see attachment db-multi-variant-field-values.png which shows the DB values for that MV field for that specific product, and compare it with vm-multivariant-field-values.png which shows that VM, despite having label values 0 and 00 in DB, it doesn't displays it in the labels box!

Is there a way to check for this issue and fix it?

Thanks!
MGS Creativa - VirtueMart Payment Plugin Experts
http://www.mgscreativa.com

Take a look at our downloads section for VirtueMart payment plugins and mouch more!
http://www.mgscreativa.com/en/online-store

razor7

  • Jr. Member
  • **
  • Posts: 355
    • MGSCreativa - Professional VM!
Any clue?
MGS Creativa - VirtueMart Payment Plugin Experts
http://www.mgscreativa.com

Take a look at our downloads section for VirtueMart payment plugins and mouch more!
http://www.mgscreativa.com/en/online-store

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3629
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Add some extra characters it use language Keys perhaps?
Jörgen
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.