Author Topic: 2.0.15d -> Bug with shipment calculation  (Read 1859 times)

Otto0815

  • Jr. Member
  • **
  • Posts: 194
2.0.15d -> Bug with shipment calculation
« on: December 16, 2012, 14:53:06 pm »
Hi there,

i've encountered a bug with the standart shipment plugin (weight, countries) and VM 2.0.15d:

If you add a product to the cart, the shipment is not shown, even not if you enter an adress and a delivery country..

if you now go to "product" in the backend and click on "select all options" for the shoppergroup the shipment price is correct in the cart (if you delete and re-add this product)...

so, now go back to "products" in the backend and delete all selected shoppergroups from the product -> then the product is also shown coreect in the cart...

I've also tried to delete the shoppergroups in the shipment plugin, but this doesn't change anything....it only works, if you select the shoppergroups in the product

In short: the shipment calculation by weight only works, if you select all shoppergroups for one time, and then delete it again....

*********
The same in german (maybe i can explain it better in my foreign language):

Die Anzeige der Versandkosten im Warenkorb funktioniert nur, wenn man im Backend bei einem Produkt einmalig die Käufergruppe(n) hinterlegt; selbst wenn man die Käufergruppe(n) dann wieder lösccht funktioniert die Versandkostenanzeige im Warenkorb immer noch....

Ich habe auch schon versucht, die hinterlegten Kundengruppen (waren eh alle hinterlegt) in den "Versandkosten-Einstellungen" im Backend zu löschen, dies brachte aber keine Änderung.

Es funkitioniert nur, wenn ich einmal die Kundengruppen im jeweiligen Produkt hinterlege.......




Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10094
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.15d -> Bug with shipment calculation
« Reply #1 on: December 16, 2012, 20:27:44 pm »
I think you should call me per phone or skype, I do not really understand what you mean. For me it looks like working as intended. Check your pn
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10094
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.15d -> Bug with shipment calculation
« Reply #2 on: December 17, 2012, 12:39:27 pm »
thanks your private message in german :-)

I was not able to reproduce the error. The shipmentmethods work with the shoppergroup of the user and the configured shoppergroup. The query is not checking any shoppergroup of a product, so I am irritated. Maybe there are other problems on your installation. I may take a look via skype. So long we can just wait if one of the others has the same bug.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Otto0815

  • Jr. Member
  • **
  • Posts: 194
Re: 2.0.15d -> Bug with shipment calculation
« Reply #3 on: December 18, 2012, 17:28:54 pm »
Gone with 2.0.15e.....