Support the VirtueMart project and become a member

Main Menu

[SOLVED]Installed VM2.0.0: no menu under components

Started by cmatte, December 28, 2011, 12:54:42 PM

Previous topic - Next topic


I had previously installed J! 1.7.3 and vm 2.0.0 and I tried many modifications at the core and so on, so I wanted to start again with a clean system. I've deleted any file and any db table, I swear, any!
I've sent J! 1.7.3 files, installed fine, then installed vm2.0.0 and it gave an error in administrative menu.And says "Info: Taking config from file.Component installed correctly.". Ok, installed sample data, ok, installed aio, ok. The problem actually is virtuemart option under components isn't there anymore. The vm page loaded from/administrator/index.php?option=com_virtuemart works (just guessed!). Shop is there. So how to solve this? I even tried deleting again any file and reinstalling, it did the same. Very weird. The package is different from the previous because I have redownloaded it. I've done this again after the first try, but the problem stays.
Can I solve this manually? Why should it do this now and not before!?

Server log says:

[Wed Dec 28 12:29:25 2011] [error] [client me] File does not exist: /administrator/components/com_virtuemart_allinone/liveupdate, referer:/administrator/index.php?option=com_virtuemart_allinone&view=liveupdate&force=1
[Wed Dec 28 12:29:22 2011] [error] [client me] File does not exist: /administrator/components/com_virtuemart_allinone/liveupdate, referer: /administrator/index.php?option=com_virtuemart_allinone


Did you deleted also the entries in the menu table? If not, uninstall the component, then go to phpmyadmin locate your database and under the "jos"_menu you`ll have to delete the entry COM_VIRTUEMART. Then delete again all VM related table and reinstall. Should work...


The cause of the fact that there was a COM_VIRTUEMART line in the _menu table but it wasn't shown is obscure to me. Anyway with your hints it worked, in particular the one about deleting that line was the trick I was missing, it wasn't deleted nor read for some reason!


i have exactly the same trouble, but i don't want to delete all my VM 2.0 installation ...

How can we reate the admin link without desinstalling and reinstalling ?


Use PhpMyAdmin.
Go in the _menu table and add a line:
(first available number here, 'main', 'VirtueMart', 'virtuemart', '', 'virtuemart', 'index.php?option=com_virtuemart', 'component', 0, 1, 1, 10007, 0, 0, '0000-00-00 00:00:00', 0, 1, '../components/com_virtuemart/assets/images/vmgeneral/menu_icon.png', 0, '', 73, 74, 0, '', 1)
where you have to substitute "first available number here" with...what's written in :)

I suggest you do it manually creating a new voice with PhpMyAdmin, if you want to use SQL, sintax is:
INSERT INTO `WhatEverYouChoose_menu` (`id`, `menutype`, `title`, `alias`, `note`, `path`, `link`, `type`, `published`, `parent_id`, `level`, `component_id`, `ordering`, `checked_out`, `checked_out_time`, `browserNav`, `access`, `img`, `template_style_id`, `params`, `lft`, `rgt`, `home`, `language`, `client_id`) VALUES
(first available number here, 'main', 'VirtueMart', 'virtuemart', '', 'virtuemart', 'index.php?option=com_virtuemart', 'component', 0, 1, 1, 10007, 0, 0, '0000-00-00 00:00:00', 0, 1, '../components/com_virtuemart/assets/images/vmgeneral/menu_icon.png', 0, '', 73, 74, 0, '', 1);

where "WhatEverYouChoose" has to be substituted by the table prefix you choose while installing Joomla.



Sorry the "first available number" is the # column id ?

I have 25 items like this

1   id   
    2   menutype
    3   title
    4   alias
    5   note
    6   path
    7   link   ...

    24   language   
    25   client_id

So i put 26 in your sql code, and the prefix also , the command has executed, but i still don't have the menu ...

Is my "26" wrong ?

The ligne has been added without errors, i can see it now in phpadmin ... Do i have to stop and start joomla to take modifications ?


Where do I find out what the next available number is? I'm having issues with this too...


A note for such as me.
I have J 2.5.1 and VirtueMart 2.0.2 and XMap 2.2.1
First it was installed XMap and created a default sitemap.
Next installed VirtueMart 2.0.2. No VM link in backend components menu!
I accidently enabled the XMap virtuemart plugin and VM link appeared in the backend menu.
I reported the bug to the XMap developer.
Your installable language for VM2:

Bruce Morgan

I published the Xmap plugin and now I have TWO VM menu links.  Unfortunaly the xmap component still give an error.



Maybe you did the manipulations suggested above and that is the reason of the 2 links?
Your installable language for VM2:

Bruce Morgan


So I'm afraid you must undo them now and keep the xmap plugin enabled.
Your installable language for VM2: