Author Topic: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed  (Read 10999 times)

H_v_M

  • Beginner
  • *
  • Posts: 13
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #15 on: December 15, 2011, 23:12:14 pm »
Update, tried to install the latest version of the 2.0 RC: M.
How easy it went on the installation with "Joomla Platform 11.2.0 Stable+Modified [ Omar ] 27-Jul-2011 00:00 GMT ", so hard it went on the version I have "Joomla Platform 11.3.0 Stable [ Dennis Ritchie ] 23-Nov-2011 00:00 GMT"

500 - An error has occurred.
JLIB_APPLICATION_ERROR_MODEL_GET_NAME
Return to Control Panel

Enough for today... waste to many time with getting it working.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #16 on: December 16, 2011, 00:09:53 am »
I fixed the first path problem already, but we still get:
"500 - An error has occurred.

JLIB_APPLICATION_ERROR_MODEL_GET_NAME

Return to Control Panel"

I need to install a whole workspace for it. Since it is still a moving target, we decided to start with the compatibility for j2.5 in january.

You try again to use j1.7.3.X which is j2.5. It is using another jPlateform.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

H_v_M

  • Beginner
  • *
  • Posts: 13
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #17 on: December 16, 2011, 09:07:53 am »
I know... I read your post about j2.5, but the think I do not understand is the fact that I have VM running smootly on the installation Banquet gaves me.

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #18 on: December 16, 2011, 11:43:14 am »

P.s.
File permissions; exact reason is unknown for me, but the host told me that 777 can not do anything wrong because the use some safety ???
Why I did this? Because I get some permissions errors by installing the sample data before.

P.s. 2 Yes, I was listed as a super user.



Some hosts are not meant for Joomla.
My dad has his own server, and Joomla will not run on it unless its 777, and it still does not work on it.


If you have to run with files 777, you need a new host

H_v_M

  • Beginner
  • *
  • Posts: 13
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #19 on: December 17, 2011, 16:12:19 pm »
Thanks for the suggestion, I will think about this.
Question I still have:

VM 2.0 should be usable on 1.7 in this year yes/no?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #20 on: December 18, 2011, 12:00:29 pm »
I just started a lot of twitters. Can you please tell us why do you think that?

Why do you just not assume that vm2 is running on j1.7? Vm2 is tested on j1.7 since it is released and since already 3, yes this are more than 100 days! VirtueMart 2 is running on j1.7.

It would be interesting to know who is constantly telling the opposite. I already found out that Fotis of K2 is telling lies about vm2. It seems that some opensource guys do not know that in opensource the normal business behaviour is still valid and it is not alllow to tell lies about a competitor. So the rumors do not stop and I am now intersted who is keeping this lies alive.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

H_v_M

  • Beginner
  • *
  • Posts: 13
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #21 on: December 21, 2011, 14:06:15 pm »
Excuse me, I did not to work on any lies / wrong information.

I just have one question / problem, I can not get VM 2.0 working on Joomla 1.7.
The last question I had was because your reaction into this thread:

You try again to use j1.7.3.X which is j2.5. It is using another jPlateform.

For me Joomla 1.7.3 is the last 1.7 version,  where I everywhere can read the suggestion to update to this, this is also the last download / version you get on the common sites.
Joomla 2.5 for me is 2.5 en not 1.7.3, but maybe I am wrong with this.

I am almost new with Joomla en VM for sure is new to me.
Near this, strange thing for me is that it is working on the installation I got from BanquetTables.pro and not on my own installation.

So, no lies / rumours. Just a question for help / suggestions where to find the solution for me problem.

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #22 on: December 21, 2011, 14:29:11 pm »
Some hosts are not meant for Joomla.
My dad has his own server, and Joomla will not run on it unless its 777, and it still does not work on it.


If you have to run with files 777, you need a new host



^^^^

JoelV

  • Beginner
  • *
  • Posts: 3
Re: VM 2.0 RC 2 K & Joomla 1.7.3 => Can't get it installed
« Reply #23 on: February 19, 2012, 18:23:59 pm »
Same problem "500 - An error has occurred. JLIB_APPLICATION_ERROR_MODEL_GET_NAME Return to Control Panel"
while trying to install VM 2.0.2 on fresh Joomla 2.5 website.
I fixed this problem by replacing GenericTableUpdater with ModelGenericTableUpdater in zip package.

Then I have a list of errors:
        Table class generictableupdaterTableProducts not found in file.
        Table class generictableupdaterTableVendors not found in file.
        Table class generictableupdaterTableCategories not found in file.
        Table class generictableupdaterTableManufacturers not found in file.
        Table class generictableupdaterTableManufacturercategories not found in file.
        Table class generictableupdaterTablePaymentmethods not found in file.
        Table class generictableupdaterTableShipmentmethods not found in file.
        Table class configTableConfigs not found in file.
        Table class generictableupdaterTableProducts not found in file.
        Table class generictableupdaterTableVendors not found in file.
        Table class generictableupdaterTableCategories not found in file.
        Table class generictableupdaterTableManufacturers not found in file.
        Table class generictableupdaterTableManufacturercategories not found in file.
        Table class generictableupdaterTablePaymentmethods not found in file.
        Table class generictableupdaterTableShipmentmethods not found in file.

Then when I try to use VM, I have some errors:
        Table class productTableProducts not found in file.
        Table class categoryTableCategories not found in file.
        Table class mediaTableMedias not found in file.
        Table class ratingsTableRatings not found in file.
        Table class vendorTableVendors not found in file.

If I rename classes then the errors disappear but I think something should be changed in install process.

Hope this help...

Joël