You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

Installlation fine,, but error on store pages

Started by gtewks, November 27, 2011, 06:44:35 AM

Previous topic - Next topic


I installed as per the instructions.  No issue all went well.
I then installed all the extensions..  again no issues.

BUT I have the following problems when you attempt to reach the store's front end.

1) IF I set the store configuration to "OFFLINE",,  then everything works fine (except of course there are no products,, ).
2) IF I then turn the store "ONLINE",, I get the following error.



You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.
Please try one of the following pages:
Home Page
Search this site
If difficulties persist, please contact the System Administrator of this site and report the error below..

Failed to connect to Permission denied

3) IF I turn the store back to "OFFLINE" and "ENABLE" all the extensions.  I get the same error (on the entire website,, not just the store pages)
4) IF I "DISABLE" the "PRODUCTs" extension but leave the rest turned on,,  I then have everything working properly (BUT of course then the store is disabled so there are no products showing,, however the store page works and the extensions show up).

So there you have it.
I basically can't "enable" the store at all without getting the error page,
and the product extension seems to have it's own issues.

I'm using Joomla 1.7.0
Virtuemart: 1.9.8.RC2M

Any ideas why this is happening?


Please use j1.7.3
I think you just must assign vm default layout to the frontpage
Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team:


I have upgraded to 1.7.3   No effect...  same issues

I've assigned both "Joomla Default" templates and I've tried using VM templates (compatible with VM2) ,,  same issues in either case.


vm templates? Please consider that vm1.1 stuff just never work on vm2. No templates, modules, plugins or hacks.

Hmm but what did I meant with vm layout, I meant with that to choose in joomla view configurator the virtuemart view virtuemart and there the layout default. Hmm maybe I should provide a picture. Here a quite good tutorial by Ed Andrea . It is a bit outdated, but most stuff is absolut correct.
Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team: