News:

Looking for documentation? Take a look on our wiki

Main Menu

Problem with multilanguage store (VM 1.9.8.H) - Joomla 1.7.2

Started by Robsone, November 12, 2011, 14:27:13 PM

Previous topic - Next topic

Robsone

Hello, I have a problem with multilanguage store. I'm trying to build a multilanguage (5-7 languages) site with store based on VirtuMart 2.0 (1.9.8.H) and when I turn on langugage filter plugin VM stops working. (looks like AJAX isn't working and I'm not able to add product to cart). When language filter is turn off everything works ok (but of course only for one language).  my test page is here: http://www.gamma.lidjan.pl Thank's for any help..

jjk

First, try to update to a newer version of VM2. Latest version is 1.9.8RC2M. I've got a similar setup using the latest VM2 version with two languages and the "Add to Cart" button works in both languages. Be aware that VM2 currently is not yet fully multilingual when using Joomla 1.7.2. It does change i.e. the cart language, but users can't switch from an english language product description to another language product description.

The only problem on your site which I did see, is that your template apparently uses a Google font, which doesn't load from the defined source: ...//themes.googleusercontent.com/static/fonts/federo/v4/FnU7BHlDZgmlIL4FzGh7QA.woff

(Apparently the Gavick guys forgot to build in fallback to a locally available font if for some reason the font itself or the font server is not available - i.e. if you are working on your website offline)
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

Robsone

I've upgraded VM to the latest version but it didn't change nothing... I'm going to try to install my site on a different server (maybe the server is the reason), because I don't have any idea where is the problem and I'm fighting with it from about 2 weeks.. 

jjk

Did you try already to disable "Using the Virtuemart jQuery" in VM2 'Configuration' - 'Templates' - 'Activate Css Styles & Javascripts'?
   
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

Robsone

Yes I tried this before and 5 minutes ago but it also didn't change nothing.. Bad thing is that I bought Boutiqe Gavick Template (which fits great for my site), but there is only a Joomla 1.7 version of this template (and this is the only reason why I've installed Joomla 1.7).   Maybe I will try to use a different template (one of the older dedicate for joomla 1.5) and I will try to install older version of joomla with VM 2.0 or VM 1.1.X . My last hope is that my server is the problem because I didn't notice any similar problems to my on the forum so there is a chance that VM 2.0 works ok..

jjk

You could also try one of these two free VM2 templates in order to find out if your template is causing the problem.
http://forum.virtuemart.net/index.php?topic=91102.0
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

Robsone

Thanks for Your help. The reason of my problem was my server (they have a some kind of Author software). I've transfered my site to a different server (http://www.womensfashion.pl) and at least now add to cart button works fine.