Author Topic: USPS V5 Validate Error  (Read 2709 times)

piperpilot

  • Beginner
  • *
  • Posts: 44
USPS V5 Validate Error
« on: April 12, 2011, 14:49:57 pm »
Reggie,

I'm encountering an issue that I can't understand.  Occasionally when people try to check out they get an error "Error: Please select another Shipping Method".  I have traced that back to the validate function.  I personally can't reproduce this but it has happened several times in the last couple of weeks.

I have attached a screenshot that one customer sent me.  I in turn logged in with his account and was able to go through the process without issue.

If there is any way you can help, that would be great.  This is the latest version of your plugin with the rate change fixes, etc.

version: USPSv5.2011.02.11 I believe (I was one of the first to donate)

While I have your attention, this version seems to have the problem with zero weights as well.  I thought you had that fixed before, but maybe it was something that didn't make it into your release tree.

Thanks
Curtis

[attachment cleanup by admin]

piperpilot

  • Beginner
  • *
  • Posts: 44
Re: USPS V5 Validate Error
« Reply #1 on: April 12, 2011, 16:17:44 pm »
OK...before you spend too much time looking at this, I might have found the issue.  Seems that IE browsers have issues with session keys and cookies.  I found this site referenced in several other threads on the same topic:

http://www2.pixellight.com/solutions/joomla_session.php

I have applied the fix and will see if it fixes the problem.

Thanks!
Curtis