Author Topic: Shipping USPS not showing on "Select Shipping Method"  (Read 11982 times)

danielpaul1

  • Beginner
  • *
  • Posts: 19
Shipping USPS not showing on "Select Shipping Method"
« on: June 19, 2010, 04:13:07 am »
First thing I did was go through the messeges on the forum to see if any of the answers helped. No such luck.

1.  I have installed USPS V4.2 and configured in VM 1.1.4 with Joomla! 1.5 per the instructions file. The green checkmark is showing in the "enabled" column in Vm admin/store/shipping module list. However, the module is not showing up in the checkout.

2.  The module does have the client account and password installed.

3.  After it didn't load, I did create a vm admin/shipping/shipper. However, I don't know what to put in the rates for it to get it to work automatically.

4.  We have been using Flex which is working on the site.

This is a raw install. Is 4.2 counting on some other files already being on the server?


... PLEASE HELP!!!!   :'(


Dan

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #1 on: June 19, 2010, 14:51:41 pm »
Did you select shipping services to offer in the module configuration?
Did you try it with VM in debug mode?

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #2 on: June 19, 2010, 18:52:22 pm »
Yes...we are using only flat rate boxes and those are selected.


ummm...debug mode? That would be a no. How do you do that?

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #3 on: June 19, 2010, 19:04:48 pm »
OK...got the debug on. What am I looking for?

Told you I was new at this!!! I'm just glad you guys are only a post away. This is a new type of project for me and I am helping a non-profit school...never done a store before!

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #4 on: June 19, 2010, 19:11:36 pm »
Newbie update... the error message is "Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods." and goes to the rates list....  It doesn't say why. I have not changed the default server setting the module loaded. Is there a different one?


<Error>
   <Number>80040b1a</Number>
   <Description>Authorization failure.  Perhaps username and/or password is incorrect.</Description>
   <Source>UspsCom::DoAuth</Source>
</Error>

Let me guess. If their account info doesn't go through the module doesn't activate and therefore cannot be seen. Am I right?

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #5 on: June 19, 2010, 19:30:41 pm »
Progress...the USPS site says you have to have additional permissions to access the API which we have to apply for.

So...if this is the reason the module isn't showing up then we know what to do. If not...do tell!!!

Thanks

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #6 on: June 19, 2010, 20:30:24 pm »
Progress...USPS had me apply for a "Web Tools User ID". Once done they sent me an email with my user name and password. THEN I had to let them know I was done with "testing" at which time they sent me new shipping server and path URLs. Now that they are installed I am waiting to see if it will let me connect.

It did not work with the provided addresses with the module.

Still not working.

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #7 on: June 19, 2010, 20:35:32 pm »
Progress...USPS had me apply for a "Web Tools User ID". Once done they sent me an email with my user name and password. THEN I had to let them know I was done with "testing" at which time they sent me new shipping server and path URLs. Now that they are installed I am waiting to see if it will let me connect.

It did not work with the provided addresses with the module.

Still not working. Current error is "Starting Shipping module: uspsv4". It is possible that it's still in process a USPS.

Any ideas?

danielpaul1

  • Beginner
  • *
  • Posts: 19
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #8 on: June 19, 2010, 20:53:30 pm »
Ta Da!!! Using the ID and Password from USPS and...

Production.ShippingAPIs.com
/ShippingAPI.dll

as the addresses I know have shipping showing up.

To expidite your contact with USPS when you call ICCC (Internet Customer Care Center--USPS) they will ask for your ID, web address the VM is on and what kind of shopping cart (in this case it is VirtueMart).

Hope this thread helps some other newbie install. Case closed (I hope...)!

bseger

  • Beginner
  • *
  • Posts: 1
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #9 on: August 07, 2010, 22:14:12 pm »
I too had this problem.  I found several posts in other places saying that the username and password from USPS is not necessary in the Shipping Module Configuration. That is false. Perhaps that was the case in earlier versions.

Another thing that is good to know is that the USPS shipping module 4.2 does not work in testing mode.  This was confirmed by tech support at USPS.

My situation was resolved by first making sure the username and password was entered. Then I emailed USPS Customer Service Center ( that address is provided to you in an email after you apply for webtools at USPS) and asked them to move our site to "production server". I then received an email from them asking what 3rd party shopping cart I was using. I responded and they then made the switch. Everything has worked perfectly since then.

caldweca

  • Beginner
  • *
  • Posts: 1
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #10 on: April 30, 2011, 18:34:44 pm »
I had this same problem, however... I didn't fill out the dimensions and weight :) Make sure you fill that out for all of your products.

timbreese

  • Beginner
  • *
  • Posts: 30
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #11 on: May 04, 2011, 20:15:26 pm »
From another post they found that the answer was to upgrade or re-install all of the files of the module. It can be downloaded with instructions at:

http://www.parkbeachsystems.com/latest/34-usps-module-for-virtuemart

Be sure to copy down your USPS username and password and your settings as these may be erased when you replace the files.

bmw2182

  • Jr. Member
  • **
  • Posts: 93
Re: Shipping USPS not showing on "Select Shipping Method"
« Reply #12 on: October 21, 2011, 01:10:38 am »
I have recently installed uspsv4.2 on Joomla 1.5.23 and Virtuemart 1.1.9.  I have enabled it, selected priority and priority international, I have a weight and measurements on the item. USPS has moved me to production. When I go to check out, I only have UPS as my mailing option.  The only way to get the USPS rates to show up is to use the original one installed USPS 3.0 - which works fine except for international shipments I get the extra characters, that's why I tried the new version.  Here is a copy of my debug....

<?xml version="1.0"?>
<RateV3Response><Package ID="0"><ZipOrigination>04970</ZipOrigination><ZipDestination>04970</ZipDestination><Pounds>2</Pounds><Ounces>0</Ounces><Container></Container><Size>REGULAR</Size><Machinable>FALSE</Machinable><Zone>1</Zone><Postage CLASSID="3"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt;</MailService><Rate>16.55</Rate></Postage><Postage CLASSID="2"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Hold For Pickup</MailService><Rate>16.55</Rate></Postage><Postage CLASSID="23"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Sunday/Holiday Delivery</MailService><Rate>29.05</Rate></Postage><Postage CLASSID="13"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Flat Rate Envelope</MailService><Rate>18.30</Rate></Postage><Postage CLASSID="27"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Flat Rate Envelope Hold For Pickup</MailService><Rate>18.30</Rate></Postage><Postage CLASSID="25"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Sunday/Holiday Delivery Flat Rate Envelope</MailService><Rate>30.80</Rate></Postage><Postage CLASSID="30"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Legal Flat Rate Envelope</MailService><Rate>18.30</Rate></Postage><Postage CLASSID="31"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Legal Flat Rate Envelope Hold For Pickup</MailService><Rate>18.30</Rate></Postage><Postage CLASSID="32"><MailService>Express Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Sunday/Holiday Delivery Legal Flat Rate Envelope</MailService><Rate>30.80</Rate></Postage><Postage CLASSID="1"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt;</MailService><Rate>5.20</Rate></Postage><Postage CLASSID="22"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Large Flat Rate Box</MailService><Rate>14.95</Rate></Postage><Postage CLASSID="17"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Medium Flat Rate Box</MailService><Rate>10.95</Rate></Postage><Postage CLASSID="28"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Small Flat Rate Box</MailService><Rate>5.20</Rate></Postage><Postage CLASSID="16"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="44"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Legal Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="29"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Padded Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="38"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Gift Card Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="42"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Small Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="40"><MailService>Priority Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt; Window Flat Rate Envelope</MailService><Rate>4.95</Rate></Postage><Postage CLASSID="4"><MailService>Parcel Post&lt;sup&gt;&amp;reg;&lt;/sup&gt;</MailService><Rate>5.15</Rate></Postage><Postage CLASSID="6"><MailService>Media Mail&lt;sup&gt;&amp;reg;&lt;/sup&gt;</MailService><Rate>2.82</Rate></Postage><Postage CLASSID="7"><MailService>Library Mail</MailService><Rate>2.68</Rate></Postage></Package></RateV3Response>

It appears to show the correct price for Priority here $5.20, however, it doesn't display?  What am I missing?