Author Topic: VM Admin menu disappeared in backend  (Read 414 times)

ROODvogel

  • Beginner
  • *
  • Posts: 5
  • A beginner
VM Admin menu disappeared in backend
« on: April 14, 2021, 10:54:58 am »
Yesterday I noticed that my VM admin menu was not visible any more. I can access most of the pages through the Joomla menu bar on top, but not all.

What I already did:
placed back database backup from 2 days ago.
Placed back FTP back up from 2 days ánd 10 days ago.
Checked the database table virtuemart_adminmenuentries (everything is published)
Checked extention virtuemart administrator menu was published (it is)
Update to Joomla version  3.9.26 (didn't help)

Joomla! version: Joomla! 3.9.25 Stable [ Amani ] 02-March-2021 15:00 GMT
Joomla! Platform version: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
PHP versie   7.3.27
VirtueMart 3.8.8 10472

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3479
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: VM Admin menu disappeared in backend
« Reply #1 on: April 14, 2021, 11:01:30 am »
What did you do immediately before the menu disappeared ? Upgraded VM, PHP, installed new extension ?

Have You tried to install VM once again over the existing install ?

Jörgen @ Kreativ Fotografi

Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28131
  • Always on vacation
    • Jenkin Hill Internet
Re: VM Admin menu disappeared in backend
« Reply #2 on: April 14, 2021, 12:39:00 pm »
Have you been editing some CSS?  eg  #admin-ui-menu { display: none; } would give exactly the appearance you have described.

Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.24 PHP 7.4.14

Jumbo!

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 738
  • Full-stack Web Developer
    • www.virtueplanet.com
  • VirtueMart Version: Always latest
Re: VM Admin menu disappeared in backend
« Reply #3 on: April 14, 2021, 18:19:19 pm »
This can also happen due to incorrect permissions. Check using another Super User account.

ROODvogel

  • Beginner
  • *
  • Posts: 5
  • A beginner
Re: VM Admin menu disappeared in backend
« Reply #4 on: April 21, 2021, 13:03:26 pm »
Thanks for all the suggestions!

What did you do immediately before the menu disappeared ? Upgraded VM, PHP, installed new extension ?

Have You tried to install VM once again over the existing install ?
I think I only added some new articles before the menu disappeared. I don't remember any special actions.
Installing VM over the existing install did not help.

Have you been editing some CSS?  eg  #admin-ui-menu { display: none; } would give exactly the appearance you have described.
No. Also the page source does not show any menu, so it is not disabled by CSS:
Code: [Select]
<div class="virtuemart-admin-area">
<div class="toggler vmicon-show"></div>
<div class="menu-wrapper" id="menu-wrapper">
<div class="vm-lang-list-container">
<input name ="vmlang" type="hidden" value="nl-NL" ><img src="/media/mod_languages/images/nl_nl.gif" alt="Nederlands (nl-NL)" title="Nederlands (nl-NL)" /> <b> Dutch (nl-NL)</b> </div>
<div id="admin-ui-menu" class="admin-ui-menu">
<div class="menu-notice"></div>
</div>
        <style>#evmver-eaeb43e304eef0de72df45c30a7915c0 { display: none;}</style>
        <div class="vm-installed-version">VirtueMart 3.8.8 10472</div>
        <div id="evmver-eaeb43e304eef0de72df45c30a7915c0" class="vm-installed-version" >
Eagle owl        </div>
        <div id="eeaeb43e304eef0de72df45c30a7915c0">

                <div style="width:auto;background:#FFFBA0;padding:8px 8px 8px 8px;font-size:14px;border:1px solid #FF6A00;">
                    <p style="text-align:left;">Like VirtueMart?</p>
                    <p style="text-align:center;font-weight:bold;">Become a Supporter</p>
                    <p style="text-align:center;">Reliable Security and Advanced Development thanks to our members</p>
                    <p style="text-align:center;"><a href="http://extensions.virtuemart.net/support-updates/virtuemart-membership" target="_blank" ><button style="width:100%;background:#FF6A00;padding:5px 5px 5px 5px;font-size:15px;">VirtueMart membership<br>Buy now</button></a></p>
                </div>        </div> </div>
Code: [Select]
#admin-ui-menu {
    border-bottom: 1px solid #94B1CF;
}

This can also happen due to incorrect permissions. Check using another Super User account.
I added a new user and added it to all groups, but also that user does not get the menu. The Joomla Extended User Rights report shows all green on the elements with "VM - *" and "com_virtuemart*".
The general settings for Virtuemart allow all rights to Super Users.

Might a corrupt article break the menu somehow?

ROODvogel

  • Beginner
  • *
  • Posts: 5
  • A beginner
Re: VM Admin menu disappeared in backend
« Reply #5 on: May 09, 2021, 09:20:24 am »
Ok. I foud it. Here is what I did to possibly help others in the future:

By diving into the code and ending up in administrator/components/com_virtuemart/helpers/adminui.php. Through some extra debug statements, it appeared that it could not find any modules to display in the AdminMenu. A look in the database table jostv_virtuemart_modules showed that it was indeed completely empty.
This post: http://forum.virtuemart.net/index.php?topic=51398.msg166289#msg166289 helped me find how to retrieve the data that should be in there, so I reran the query that filled this table from administrator/components/com_virtuemart/install/install_essential_data.sql
And then the menu was back again! :)

It still remains unclear why a backup of the database and a new install did not fix this. The only pointer I see is that when running the query manually, it gave a warning about truncating the is_admin values... I am not going to dive into this deeper though. Maybe next time. ;)