News:

Looking for documentation? Take a look on our wiki

Main Menu

English translation is no longer working

Started by goldkabel, February 25, 2020, 13:28:22 PM

Previous topic - Next topic

goldkabel

VirtueMart 3.6.10 10211
Joomla! 3.9.15
PHP 7.3

Hi everyone,

since an unknown time, my english translation is no longer working in Virtuemart (Global Shop configuration is german). When I switch from the german to the english page, the pages remain in german (both products and categorys) and the strings, which are translated through override, does not seem to work anymore either.

You can take here a look for reference:

https://goldkabel.de/index.php/de/products/audio/cinch-kabel/profi-cinch-stereo

Everything beside virtuemart is still working as intended. I cannot tell when the english site broke, there where no problems and no major changes on the site before.


jjk

#1
I don't see any script loading errors on your site. My guess is that your hitsteps extension is at fault. I seems to have an automatic language selection script. Might also be a problem with your jchoptimize cache settings.
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

goldkabel

Hi jjk,

thanks for your help. Hitsteps was first installed a few days ago, the problem was already existing before.

I tried to change the jchoptimize cache settings and disabled it completly with no changes unfortunately...

Studio 42

Some system plugin call virtuemart and set language before language is loaded in Joomla
so search for VmConfig::loadConfig();
And replace with VmConfig::loadConfig(false,flase,false);
Another solution is to reorder the plugins so Joomla language plugin are called first.
Free XML sitemap generator [url="http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm"]http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm[/url]  , Free Unused Image cleaner [url="http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm"]http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm[/url]
Language Switch in product & category [url="http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm"]http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm[/url]
More extentions [url="http://shop.st42.fr/en/"]http://shop.st42.fr/en/[/url]

jjk

#4
In your first post you wrote you are using VirtueMart 3.6.10 10211. Are you sure? The generated source code of your product page doesn't look like that. I even noticed some code pointing to the ancient 'Falang' translation component, which doesn't work with VirtueMart by the way.

Maybe also try to locate where the language key/string TPL_PRODUCT_CODE="Product Code:" comes from. Joomla's 'Debug Language' option in the 'Global Configuration' could help with that - perhaps your template? That language key/string is not part of the original VirtueMart language files. Also the English language key/string is loaded when you click the German flag, while the language key TPL_PRODUCT_CODE shows up when you click the English flag, which means it is untranslated. Looks like languages are mixed up in the database.

With jchoptimize enabled, some things are difficult to see.

QuoteI tried to change the jchoptimize cache settings and disabled it completly with no changes unfortunately...
You would also have to clear the jchoptimize cache files and your browser cache to see a difference.
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

Studio 42

jjk, i'm pretty sure the problem is what i explained. It's not a cache problem, because he have mixed language.
Free XML sitemap generator [url="http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm"]http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm[/url]  , Free Unused Image cleaner [url="http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm"]http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm[/url]
Language Switch in product & category [url="http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm"]http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm[/url]
More extentions [url="http://shop.st42.fr/en/"]http://shop.st42.fr/en/[/url]

jjk

#6
@Studio42
You might be right if the site uses an outdated version of Falang. The latest versions seems to have some fixes to work with VirtueMart and claims that it takes care of the plugin order automatically. However, I wouldn't recommend to use it. I don't know anything about the current Falang version, but if I remember correctly, earlier versions achieved compatibility with VirtueMart by switching itself off for VM pages. Using the Joomla/VM translation system means a lot less headaches in the long run. In addition, the hitsteps extension currently is causing timeouts and the EU-Cookie plugin doesn't work as it should either.
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

eu4ria

Transliteration doesn't work. Old way of fixing it, doesn't work eather:
in administrator-components-virtuemart -helpers - vmtable.php
$unicodeslugs = VmConfig::get ('transliterateSlugs',false);
was changed to
$unicodeslugs = VmConfig::get ('transliterateSlugs',true);

No luck at all

Studio 42

Free XML sitemap generator [url="http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm"]http://shop.st42.fr/en/catalog/products/virtuemart-2-sitemap.htm[/url]  , Free Unused Image cleaner [url="http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm"]http://shop.st42.fr/en/products/virtuemart-media-folder-clear.htm[/url]
Language Switch in product & category [url="http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm"]http://shop.st42.fr/en/categories-tools/multi-language-for-virtuemart.htm[/url]
More extentions [url="http://shop.st42.fr/en/"]http://shop.st42.fr/en/[/url]

dimkosk


Milbo

Quote from: eu4ria on March 31, 2020, 12:27:39 PM
Transliteration doesn't work. Old way of fixing it, doesn't work eather:
in administrator-components-virtuemart -helpers - vmtable.php
$unicodeslugs = VmConfig::get ('transliterateSlugs',false);
was changed to
$unicodeslugs = VmConfig::get ('transliterateSlugs',true);

No luck at all

This just changed the default value, if no value is set.
Should I fix your bug, please support the VirtueMart project and become a [url=http://extensions.virtuemart.net/support/virtuemart-supporter-membership-detail]member[/url]
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/