Author Topic: The value of one language variable is not displayed  (Read 1388 times)

AnSit

  • Jr. Member
  • **
  • Posts: 121
The value of one language variable is not displayed
« on: February 08, 2020, 22:23:44 pm »
Please tell me what and where there may be an error if the variable "COM_VM_LOADED_STORED_CART" does not change to its value.  On the front end it is displayed: COM_VM_LOADED_STORED_CART. What I just didn’t do anyway doesn’t want to display its value anyway.
It is in the language files that I have already placed in different directories.

/components/com_virtuemart/language/en-GB
/language/en-GB

Tell me, please, what else can I do and check?

VirtueMart 3.6.10 10211
Joomla! 3.9.15

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2857
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: The value of one language variable is not displayed
« Reply #1 on: February 09, 2020, 12:35:52 pm »
Use JOOMLA language override for admin and tick box "For Both Locations".

Jörgen @ Kreativ Fotografi
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3656
  • using Matomo instead of Google Analytics
Re: The value of one language variable is not displayed
« Reply #2 on: February 09, 2020, 13:41:06 pm »
The line is called from your-root-folder\components\com_virtuemart\language\en-GB\en-GB.com_virtuemart.ini
COM_VM_LOADED_STORED_CART="Your previously stored cart content has been loaded"

This notice is displayed if a logged in shopper has previously add a product into the cart, but didn't check out before the session ended.
If the string doesn't show, I assume you are using a third party checkout.

If you want to hide it, use the override as Jörgen stated  above:
COM_VM_LOADED_STORED_CART=""
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

AnSit

  • Jr. Member
  • **
  • Posts: 121
Re: The value of one language variable is not displayed
« Reply #3 on: February 09, 2020, 16:55:36 pm »
Thank you for your support and for responding so quickly to help!

Yes, through the redefinition of language variables, it turned out to replace the display in the frontend of the variable name with the value of this variable.

But please tell me why this particular variable is not read from the file? I’ve even overwritten these files from the original installation and copied them to different folders - I still don’t want to display the value of this variable. Whatever I do, her name is always displayed on the site.

Tell me what could be the problem? This is only with this variable.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3656
  • using Matomo instead of Google Analytics
Re: The value of one language variable is not displayed
« Reply #4 on: February 09, 2020, 17:17:54 pm »
Perhaps clear the Joomla Site cache and your Browser cache. If that doesn't help, turn on Joomla 'Debug Language' in the Joomla configuration, to see which language files are loaded. If you use a third party 'one page checkout', that might have it's own language file.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

AnSit

  • Jr. Member
  • **
  • Posts: 121
Re: The value of one language variable is not displayed
« Reply #5 on: February 09, 2020, 18:31:16 pm »
Thanks for the tips!
Yes, I checked the debug mode. The language file containing this variable and its value is loaded successfully.

And as you suggested, I decided to still disable the one-page basket plugin. And you know, after updating the page, the value of the variable appeared! Yes, he really has his own language file, but when I entered this variable and its value in it and turned on the plugin, the value of the variable was not displayed anyway. Here is such a strange behavior and an incomprehensible situation.

But it’s good that it can be solved at least through override.