News:

Looking for documentation? Take a look on our wiki

Main Menu

"Ask a question about this product" isn't translated

Started by Rune Rasmussen, April 03, 2017, 23:13:13 PM

Previous topic - Next topic

Rune Rasmussen

Anyone else noticed this strange thing, that "Ask a question about this product" isn't translated in product details?



I've seen it two different sites, with different design, and also tested default.


If I add a override for COM_VIRTUEMART_PRODUCT_ENQUIRY_LBL it will be translated, but it's not loaded from the language file. But then, if I activate language debugging it's loaded from the language file, and no error reported ...


Oh btw, if I add COM_VIRTUEMART_PRODUCT_ENQUIRY_LBL to the language file in admin, it also works.


There is a Gremlin in the system! ;)
Rune Rasmussen - [url="https://www.syntaxerror.no/"]https://www.syntaxerror.no/[/url]

Norwegian Translation Team

jjk

QuoteAnyone else noticed this strange thing, that "Ask a question about this product" isn't translated in product details?
If you mean that you see the language key when the English site language is being used, it might be because it is an old updated shop, where the VM English language files are still present in the Joomla administration language folder. They are being loaded (should be loaded) from the ...administrator\components\com_virtuemart\language\en-GB folder since long time ago.

The translations into other languages are still being loaded from the Joomla administration/language folder, because ctransifex doesn't have the capability to generate language packs for installation into the component language folders.
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]

Rune Rasmussen

No, I see "Ask a question about this product" - it's not translated.

But yes, it truly is because "/administrator/language/en-GB/en-GB.com_virtuemart.ini" (BE) still exists, and weirdly enough overrides "/language/nb-NO/nb-NO.com_virtuemart.ini" (FE)

I would say that looks a loot like a bug. Still, best would be to ensure those English files are being deleted on update, or at least notify the users about the need to delete them.
Rune Rasmussen - [url="https://www.syntaxerror.no/"]https://www.syntaxerror.no/[/url]

Norwegian Translation Team