[SOLVED]Error 403 Access denied in user registration after Joomla 2.5.18 upgrade

Started by guidocx842, February 17, 2014, 16:19:32 PM

Previous topic - Next topic


Good morning,
since I upgrade to Joomla 2.5.18 I'm no more able to register users on my Virtuemart 2.0.26d.
When I press the register button I go to a 403 access denied page.
I see that in that version of Joomla http://www.joomla.org/announcements/release-news/5530-joomla-2-5-18-released.html they include the enhanced password hashing via PHPass. So, when I see my webserver logs and see

mod_fcgid: stderr: PHP Warning:  is_readable(): open_basedir restriction in effect. File(/dev/urandom) is not within the allowed path(s) in var/www/clients/client1/web30/web/libraries/phpass/PasswordHash.php on line 51 I suppose that I'm not more able to register my Virtuemart user due to that. So, in my open_basedir configuration I added /dev/urandom.

After that, the warning disappear but I still not able to make registration possible on my Virtuemart and I still see the 403 access denied page.

Do you know if somebody notice something similar? Do you think that there is something to change in Virtuemart after the latest joomla release?

I can share with you some links of people that are experiencing same problem with other extensions...



Thank you so much. Regards.


Reading my topic I see that I didn't say to you how to try to replicate the problem.

Joomla 2.5.18 + Virtuemart 2.0.26d

Create a new menu item where Virtuemart user can manage their account (login and register).
Compile all necessary fields, than press Register.
If you replicate the problem, you'll see the Joomla 403 Access Denied Page typical page.

Please, may you try to do this simple steps and say me if you're able to replicate the problem?

Thank you so much!  ;)


Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum


Hi jenkinhill,
thank you for your answer.
I discover that I forget to activate user registration.
So, after the open basedir configuration that link to /dev/urandom, if I activate user registration it's all ok.
Thank you so much for your interest. Have a nice weekend!  ;)


Then it would be nice if you set it to solved. and good that you gave the reason. :-)
Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team: http://extensions.virtuemart.net/


Quote from: Milbo on February 24, 2014, 00:32:26 AM
Then it would be nice if you set it to solved. and good that you gave the reason. :-)

Yes. You're right. Sorry, I forget it. Thank you very much for your support! Regards.