Author Topic: cart content disappears if article costs 1000  (Read 1038 times)

ang

  • Beginner
  • *
  • Posts: 1
cart content disappears if article costs 1000
« on: November 12, 2013, 14:19:40 pm »
Hi everybody,

I'm a beginner in using Joomla; I'm experimenting on a test-site before trying to set-up an official website for my company.
I've installed VM 2 because I need e-commerce feautures.

Since I've had several troubles with cart management trying using a self-made shop, I restarted from scratch using the example files provided with VM and adding my products to see the cart behaviour.

I left original shipment and payment methods provided by the demo shop.

I created a new product in a new category, with price 500 ( currency is €)

Then I tried the cart with the demo products and my product and everything went fine, except that I always have to choose the payment type even if only one is defined.

Then I added a second product, by cloning the first and changing name and price to 1000.

When I buy this one, after I selected and saved in  page "choose your payment", the cart becomes empty.

If I change the price and set it below 1000 this issue disappears.

This trouble appears when I act as a registered customer; if I try as a not-registered guest the problem is similar, except that sometimes at the checkout I also have to select the shipment method and when I click to select I receive the message that there's not a shipment method defined for me.

I already tried the following after reading the forum:

1 using Jqueryeasy to solve potential library conflicts

2 deactivating any template using Jquery (I was trying Vertex by Shape5 and I switched to e-Beeze)

3 deactivating VM own libraries

4 I checked that Joomla cache is disabled

5 I set the browser to accept all cookies (FireFox or IE)

6 with fireBug I can't see any script issue, but I'm not a programmer so I can't assure this

7 I've checked that shipment/payment methods are valid for all countries/weight/ZIP (but they are the demo methods, anyway creating mine the issue remains)

The trouble always survived



My configuration is:

Apache server, provider: altervista

php 5.2.17

Joomla! 2.5.14

VirtueMart 2.0.24

I basically use FireFox 25.0

last note: I'm an italian user, so I use joomla in italian and I have translation for VM in italian, I don't know if this can be important

Thanks for any hint you may provide.

Greetings

Andrea

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: cart content disappears if article costs 1000
« Reply #1 on: November 21, 2013, 14:41:36 pm »
This is really strange, I cannot reproduce it.
Can you please try with 2.0.24a? Because we set another precision there.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/