Author Topic: Zero 0.00 price & order issues  (Read 1374 times)

Stonedfury

  • Jr. Member
  • **
  • Posts: 266
    • Stonedfury
  • Skype Name: Stonedfury
  • VirtueMart Version: 2.0.24
Zero 0.00 price & order issues
« on: June 27, 2013, 21:41:47 pm »
I did a search looking for delete issues of orders with zero cost and other variations of such. We have a new product that is downloadable via the virtuemart paid plugin for download sales. The product is free 0.00 cost and shipping is of course free as well. Using weight 0.001 for product and a set up shipper for that. Skipping to the point. Product is purchased and downloaded fine. BUT if you do a test and then go to delete the order it will not. I had to go into the db and through order history and such to find it and then delete.

Also if you have deleted a shipper from say LONG ago and then go to delete an order from that period too. (don't ask why, I just had to) I go this error
Quote

        vmError: Seems the used shipmentmethod got deleted
        vmError: TableOrders delete Order shipmentTable = #__virtuemart_shipment_plg_ `virtuemart_order_id` = 845 dbErrorMsg
        vmError: VirtueMartModelOrders::remove 845
        Order could not be deleted.


Yet it did delete the order from what I can tell. I do not see it in the db but that is just a strange error.

Ideas?
No such thing as a stupid question, only a stupid answer. I won't ask if I know the answer or found it using the search as you suggested.

K&K media production

  • VirtueMart Developer Team
  • Global Moderator
  • Full Member
  • *
  • Posts: 838
  • VirtueMart Version: VM3 on J3
Re: Zero 0.00 price & order issues
« Reply #1 on: June 28, 2013, 03:00:07 am »
order data is stored in different tables (order, order items, shipment, payment,...) and if there is a entry missing in one of the tables, it results in this error messages

Stonedfury

  • Jr. Member
  • **
  • Posts: 266
    • Stonedfury
  • Skype Name: Stonedfury
  • VirtueMart Version: 2.0.24
Re: Zero 0.00 price & order issues
« Reply #2 on: July 01, 2013, 18:44:27 pm »
order data is stored in different tables (order, order items, shipment, payment,...) and if there is a entry missing in one of the tables, it results in this error messages
I am aware of this.

I am not having issues with vm not handling 0.00 price until I delete. I am aware that there has been a zero cost bug and it was worked on in latest testing but cannot use that until it is 100% stable. For now I suppose I will be using phpadmin to remove any issues I receive.
No such thing as a stupid question, only a stupid answer. I won't ask if I know the answer or found it using the search as you suggested.