Add to cart not working properly in IE8 and VM 2.0.21E

Started by patrik60, June 17, 2013, 17:16:20 PM

Previous topic - Next topic

patrik60

Hello

I just tested VM 2.0.21E on Firefox and on IE8. No problems with Firefox. But on IE8 when adding a product to the cart and then clicking "show cart" on the popup I am guided to the homepage of the shop instead to the cart. In the previous version 2.0.21d the popup was not even shown.

Regards
Patrik

J 2.5.11
VM 2.0.21E


EDIT: May be this is a language problem: My shop is bilingual. When I use German as standard site language I get the above described problems but only on the english site. When I use English as standard site language I don't get these problems. And as I said this happens only in IE8. (IE10 and FF work fine. I couldn't test it with IE9)

Milbo

Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Jörgen

Hello Milbo

Yes, it is still used.  ;)

In our company we have computers running Windows XP. Company policy prohibits us from using other browsers, for example Firefox or Chrome.

best regards

Jörgen @ Kreativ Fotografi

Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

patrik60

I would like to forget it, but I know that some of my customers are still using it.

Regards
Patrik

AH

From our stats we have about 15% still using it

I use fancybox for the popup and do not have a problem with adding to cart
Regards
A

Joomla 3.10.11
php 8.0

patrik60

I think I have found the problem: After installing the new version of VM the language settings in the VM configuarion -> Multilingual shop are empty. In this moment the shop is not correctly translated. When using the second language (in my case English) there is a mix between English and German because only the strings from the vm language files are translatetd, when choosing German as default language for the site.

After selecting the languages in the configuration (in my case German and English) everything works fine with or without fancybox.

The problem with the popup only happens in IE8, the problem with uncorrect translation in every browser.


[attachment cleanup by admin]

patrik60

After installing version 2.0.21f the language settings of VM are overwritten again.

lindapowers

Quote from: patbe60 on June 18, 2013, 17:15:06 PM
I think I have found the problem: After installing the new version of VM the language settings in the VM configuarion -> Multilingual shop are empty. In this moment the shop is not correctly translated. When using the second language (in my case English) there is a mix between English and German because only the strings from the vm language files are translatetd, when choosing German as default language for the site.

Yes I noticed this too recently.

jjk

I just had the same effect as shown in patbe60'screenshot at one of my local test sites. In my case for some reason the file .../administrator/language/de-DE/de-DE.xml got lost - but that's a Joomla language pack file. However, restoring that file solved the problem.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

patrik60

Solved with 2.0.21g

lindapowers

#10
Quote from: patbe60 on June 26, 2013, 23:27:34 PM
Solfed with 2.0.21g

No is not. The languages are kept in the multilingual config this time but some language strings are lost with new installation, they will appear again in english (even if you have your language file previously installed and working). So there is something wrong with the language files that will require an installation of the language pack after installing vm core and aio.

Not a big drama having to install language packs but just to let you know.

Regards