[SOLVED] For registered FE users: Entire cart disappears after 2.0.16 upgrade?

Started by JoomJohnny5, January 04, 2013, 21:03:19 PM

Previous topic - Next topic


I noticed for ONLY front-end logged-in "registered" level users the entire cart (all Cats, Products, everything ) disappears.

Admins and guests will see the cart fine when logged in, so only "registered" level users cannot see the cart.  They are assigned to default shopper group so this confuses me.  I tried creating new shopper group as default which does not help. 

Noticed this after the 2.0.16 upgrade but I reverted back to 2.0.14 stable and still have the same issue.  Also tried disabling multiple other components and plugins for conflicts, with no luck.

Also, I cannot see where to edit the user group and module lists as described in documentation?:  http://virtuemart.net/documentation/User_Manual/User_Groups.html

Any thoughts ideas on this greatly appreciated, thank you?

VM 2.0.16
Joomla! 2.5.8
PHP: 5.2.17
There's only one remedy for mulletosis.


Looks for me like a pure joomla ACL misconfiguration. The documentation you are using is for vm1.1, please use docs.virtuemart.net
Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team: http://extensions.virtuemart.net/


Thank you for steering me!  All permissions (and registered users) settings are still default as far as I can see: Registered has "site login" allowed, with all else "inherited," and all Public permissions set to "not set"

All menu items and modules are public

Do you know how this might affect the VM component for registered users? I see nothing about component permissions ? 

Thank you!
There's only one remedy for mulletosis.


Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum


I solved this for future registered users by 1) Simply checking 'Public' in the Viewing Access Level setting for Registered Users, then 2) I had to go add Public as a assigned group one-by-one for all existing users who registered before this change

Not sure why this is not the default setting, or why it affected Virtuemart only.  Maybe it got changed along the way on my end, but I hope this helps others out!

Thanks for the comments yall!
There's only one remedy for mulletosis.