You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

When I add a product, nothing happen

Started by nino59, November 23, 2012, 11:49:08 AM

Previous topic - Next topic



I have j2.5.6 + virtuemart 2.0.14.
When I add a product, nothing happen. IN javascript console I have:
"Uncaught TypeError: Cannot read property 'settings' of undefined  in "vmprices.js".

Someone can help me?



It is a javascript conflict that is not related to vm but related how your site works and how many components or templates you have installed that uses jquery and load more than once jquery library. You will find a lot of posts on the forum regarding those issues. Please check your site header using firebug and check what javascript you are loading and try to fix it. Also you will be nice if you could post here a live url so be able someone test your site and help you out to resolve it.
Best way always is to test with joomla beez20 template and vm default template to see if the conflicts exists, if yes, then maybe a component or module or plugin loads some "bad" javascript that produces conflicts.

Use firebug to examine your site code and styling .. also for checking js conflicts ...

Javascript conflicts:

Similar issues:

Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!