News:

Looking for documentation? Take a look on our wiki

Main Menu

[SOLVED] Not able to add product or custom fields

Started by cod3gen, November 10, 2012, 11:47:26 AM

Previous topic - Next topic

cod3gen

Hello all!

I just got this error:
Quote500 - **An error has occurred.**

Method getErrors not defined

**Return to Control Panel**
Call stack
#   Function   Location
1   JAdministrator->dispatch()   /var/www/vhosts/renel.no/httpdocs/administrator/index.php:46
2   JError::raiseError()   /var/www/vhosts/renel.no/httpdocs/administrator/includes/application.php:164
3   JError::raise()   /var/www/vhosts/renel.no/httpdocs/libraries/joomla/error/error.php:251


**Joomla! Debug Console**
**Errors**
Method getErrors not definedCall stack
#   Function   Location
1   JAdministrator->dispatch()   JROOT/administrator/index.php:46
2   JError::raiseError()   JROOT/administrator/includes/application.php:164
3   JError::raise()   JROOT/libraries/joomla/error/error.php:251

**Session**

Anyone know a fix for this? Not really sure when it happend, and how it happend, but i think it might be during last update, i have not added product since then and it worked before..

Thanks,
Stian

jenkinhill

This sure looks like a Joomla error, getErrors method was present in Joomla 1.5 but you do not tell us any of the versions you are using.

Maybe the host changed the PHP version? In any case I think you need to ask on the Joomla forum, in the meantime revert to your last working backup.

Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

cod3gen

#2
Joomla version is 2.5. VirtueMart version is 2.0.13 (just upgraded from 2.0.12f or something to see if it fixed it.)
No upgrades done to PHP..

cod3gen

Figured it out.
It was SH404SEF Db query cache for Joomla that did it. Disabled it and it functions as it should again