VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: Vejgaard on April 17, 2012, 22:03:37 pm

Title: No email for customer after place order
Post by: Vejgaard on April 17, 2012, 22:03:37 pm
I've now installed my Virtuemart 2.0.6 and got it mostly to work. But when I place an order there will be no mail or pdf file to the customer's mail. So they can not see they have ordered. What can I do to fix this?
Title: Re: No email for customer after place order
Post by: John2400 on April 18, 2012, 11:35:12 am
Vejgaard,
Hi - could yopu expand on what happened - * eg You purchased a product using a test email that is redirected to your home computer or an email that you can open some where?

* when you pressed confirm - what ? purchasing method did you use. what shipping?

can you set shipping to free and payment to free - just two test options and then test a product again - the result will show that it is not a shipping, nor payment problem but an email issue.?

Just step us through so that we can see what you did and maybe what errors happened.

And did the seller or vendor receive an email?  but the buyer did not? there are reasons why I am asking this?
Title: Re: No email for customer after place order
Post by: Vejgaard on April 18, 2012, 15:32:33 pm
Jeg har teste med gratis forsendelse og betaling. Så fik jeg mail. Så brugte jeg hvor det kostede at sende pakken og det virkede også. Da jeg valgte at bruge ePay Kort som betaling går det galt. Så kan være jeg skal kontakte dem.

http://virtuemart.dk/virtuemart/?page_id=92
Title: Re: No email for customer after place order
Post by: http on April 18, 2012, 20:51:20 pm
I have the same problem.
I use the phpMail Option with Joomla 2.5.4 and VM 2.0.4
i was able to send the confirmation mails with an earlier version but since the update (at least I think since the update  ;) ) no registration-confirmation or purchase-confirmation mails are send to the customer.
But I was able to send a mass-mail to all users via joomla. So I think the phpMail does work and the problem is virtuemart.
Does anybody has a solution for this problem? In an earlier thread they suggested to check if the product was in stock but that didn't work for me.

 
Title: Re: No email for customer after place order
Post by: John2400 on April 19, 2012, 00:32:09 am
http ,

there is a 2.0.6 stable version out -  backup, update and see how you go - first http://dev.virtuemart.net/projects/virtuemart/files


Vejgaard, sorry my language skills are not able to translate - if this is a paypal issue then - It needs to go into forum" pligins , payments, shipment & others -
On that forum is the expert in paypal ? and most solutions for your issue are there .
Title: Re: No email for customer after place order
Post by: Vejgaard on April 24, 2012, 15:10:38 pm
All is update but it will not send mails ud when i use ePay as modul.

Any one have some solution?
Title: Re: No email for customer after place order
Post by: gjrweb on April 24, 2012, 16:02:33 pm
Same problem here!

We are using standard shipping and paypal or iDeal on our shop. Joomla! 2.5.4 and Virtuemart 2.0.6.

Email is not send to store owner, only after changing the order status to "confirmed".

Very wierd, the shop owner should be notified on new orders! Please fix this asap!
Title: Re: No email for customer after place order
Post by: uschmi on April 25, 2012, 16:19:51 pm
Same problem here with VM 2.0.6 and Joomla 2.5.4
Title: Re: No email for customer after place order
Post by: Vejgaard on April 26, 2012, 13:38:08 pm
So the problem is in virtuemart new code system. Okay we need to finde the code that send mails out.
Title: Re: No email for customer after place order
Post by: TCF on April 28, 2012, 05:23:17 am
This thread solved the problem for me :

Code: [Select]
http://forum.virtuemart.net/index.php?topic=96541.0
Just go to your database (I'm using PHPMyAdmin) and go to your online store database, find table "XXX_virtuemart_userinfos" (XXX depends on how you set the name in the beginning, mostly using JOS" and change/edit the Admin's "virtuemart_user_id" from 42 to 1. It works for me, invoice mail sent to customer's email.
Title: Re: No email for customer after place order
Post by: Vejgaard on April 28, 2012, 12:07:12 pm
THX but i does not work.
Title: Re: No email for customer after place order
Post by: Apewire on May 07, 2012, 18:33:16 pm
I've got the same problem (J 2.5.4/VM 2.0.6 and iDeal module), the change admin user ID trick doesn't work here (also my default admin user ID is 62). Does someone got any other suggestions ?   
Title: Re: No email for customer after place order
Post by: yayadk on May 15, 2012, 21:13:36 pm
i have the same problem.. maybe even more starnge
joomla 1.7 and VM 2.0.3
After buying no emails are sent BUT after changing the status to "sent" the customer gets right away an mail about status changed and the admin gets an email about confirmation of a user that just bought
:-(... what????

Hope anyone can find a solution to this
Title: Re: No email for customer after place order
Post by: vverloop on May 16, 2012, 21:20:16 pm
- bug in cciDEAL Platform (another payment method)
- bug in Virtuemart 2.0.4 (fixed in 2.0.6)
- by default empty invoices path, please fill in
Title: Re: No email for customer after place order
Post by: vverloop on May 16, 2012, 21:23:11 pm
i have the same problem.. maybe even more starnge
joomla 1.7 and VM 2.0.3
After buying no emails are sent BUT after changing the status to "sent" the customer gets right away an mail about status changed and the admin gets an email about confirmation of a user that just bought
:-(... what????

Hope anyone can find a solution to this

First please update your Joomla v1.7 to v2.5. Joomla v1.7 is "end of life". Also there is a new version of Virtuemart.

Also since Virtuemart v2.0.2 something is changed: New billing system incorporated in core: after order payment confirmation, the invoice is sent directly to shopper with the mail.
Check the changelog. Maybe your 3rd party Payment Method needs an update.
Title: Re: No email for customer after place order
Post by: Apewire on June 06, 2012, 23:15:55 pm
After updating cciDEAL Platform (to version 254ST) & the VM iDeal payment plugin the automatic e-mails work again.