You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

in cart all prices 0

Started by skiv86, October 20, 2011, 23:03:32 PM

Previous topic - Next topic


i installed vm 1.9.8 all modifications  and sample data, no chance any configurations/
go to shop and by something and then go to shop cart, but in it all prices 0:

Product prices result   0,00 €   0,00 €   0,00 €
Edit shipping    No shipment selected    0,00 €       0,00 €
Edit payment    No payment selected       0,00 €   0,00 €
Total:    0,00 €    0,00 €    0,00 €

who can help me?



This problem has been solved in the J version .
Please update.


this problem i have in 2 last versions.



But do you have it with the J version?


We have installed VM2 (latest version as of yesterday) on a Joomla1.7 installation and this is happening to us too.
Prices show fine at product view, but 'add to cart' shows all values as £0.00.
Any help would be gratefully accepted as the site was supposed to go live on 21st.



Just installed VM 2.0.0 on a J1.5.25 with a rocket theme Zephyr template. I have the same problem.
No products or prices added to the cart. I have turned all prices on in config to make sure nothing could be missed due to it being hidden.
The "Add to Cart" button takes you to the cart so an action is being triggered.

Virtuemart JQuery library has been switched off.
Product Scripts have been switched on and off
External Google Jquery Library has been switched on and off

Result in Cart is:
Product prices result    0,00 $    0,00 $    0,00 $
Standard ShippingStandard Australia wide post    1,50 $       16,50 $
StandardVM Standard    0,00 $       0,00 $

Clicking on the checkout button then leads to
with the error "there are no products in your cart." Understandable.

This is a pretty serious problem for e-commerce. The cart is always empty.   

Take a look here


Additional to the previous post i have also used the rhuk-milkyway template with the same result when troubleshooting the JQuery potentials.


Hi ,

Before you do anything . I think you have you currency calculations wrong.

Go to Configuration>>currencies>>Australia>> click and open this and you will see that the fullstop  for money is actually set as a comma change the comma to a full stop and maybe the calculation will work.

* I presume you are australian company?

Also I could not find your shop from the front end of a really great website. maybe you have hidden it or it just does not stand out.

I think this setting was fixed in k version so I'd check my updates.

I changed my site recently from 1.5 to 2.5.1 Joomla ( and virtuemart) - I suggest that If you don't have lots of products then do that now and work on 2.5.1 and VM 2.0.1 ( g) etc .

Too hard to move later -

Let me know how you went.

another ausie