Not able to add product categories, user groups - links to html page?

Started by JinXter, February 23, 2012, 19:45:00 PM

Previous topic - Next topic


Hi guys,

I took a while but i finally started using virtuemart  ;D
Evertyhing looks to run smooth on first sight but when i tried
to add a  new user group, a product group i don't get to the correct page....
I get a somewhat plain html page, ( see attachment)

Uploaded with

The strange thing is that i can add a product, (click on new button) with no problem.

Can someone help me out?

Im using joomla 2.5 + virtuemart 2.0
i tried joomla 1.7 as well but the same result...



Just to bump this, I get the same when I go to add or edit a category.  The errors reported are:

Warning: Invalid argument supplied for foreach() in /home/sites/.../public_html/joomla/administrator/components/com_virtuemart/views/category/tmpl/default.php on line 75


Fatal error: Call to a member function getListFooter() on a non-object in /home/sites/.../public_html/joomla/administrator/components/com_virtuemart/views/category/tmpl/default.php on line 140

The lines, respectively, are:

foreach($this->categories as $i=>$cat){


<?php echo $this->pagination->getListFooter(); ?>

I'm running Joomla 2.5.1 with VM 2.0.0.

If I change to VM 2.0.1N then I can edit categories but other issues arise so I'm preferring to stay with 2.0.0 for now.

If anyone has a fix for this specific thing then I'd be much obliged, since it is holding up my site development now.


I'm running into the same problem as JinXter. And haven't found a solution yet. Can anyone point me in the right direction?
VM2.0 - Joomla 2.5.1
Would be most appreciative.
Regards, Richard


Same problem here. With the same parameters.
Isn't there a fix for this?


Same problem here.

When i try to create new Manufacturer or new Product Catecory or new Manufacturer category Gui provides Textual menu.
Like link would point in wrong place.

I have
- Fedora Linux 16  64bit
- Mysql 5.5
- Apache 2.2.22
- PHP 5.3.10
- Joomla 2.5.1
- VirtueMart 2.0.0


Please update to vm2.0.2 !
The problem is always an incompatibility of joomla 2.5 and virtuemart 2.0.0 ! But this is already solved since weeks (version 2.0.1C or so).
Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team:


Thanks.  That was fast.
I applied the fix and it seems to work a treat.



Thanks you guys!   ;)

Ill give it a try,

was glad that i was not the only one having problems