Author Topic: [Solved] Optional account creation not working :<  (Read 64404 times)


  • Beginner
  • *
  • Posts: 2
[Solved] Optional account creation not working :<
« on: February 06, 2012, 16:35:13 PM »
Greetings forums!

I seem to have a kinda tricky problem since the whole google-world doesn't know about this. I really really hope, someone here might have stumbled upon the same thing, because it's driving me totally insane.

So, our customer wants his shop to accept guest buyers as well, so we activated "optional account creation". That means, the shop visitor can choose wether to create an account or to buy as a guest, right? Thing is: with "optional account creation" activated, no one gets through the registration form without entering a username and password combo. VirtueMart says something like "check if the form is filled out completely and correctly" (I don't know the exact error msg, since the shop is in german, sorry!) even if everything is filled in.

What's happening there? Is VirtueMart mistakenly missing the user/pw-combo? Or is there more to set up than just activating "optional account creation"?

Thank you for any help!

PS: Oh, and I'm using VM 1.1.8 and Joomla 1.5.23 (yeah I know, newer would be better, but, alas, the customer's server is running PHP4)
PPS: Please excuse my so-so english, I unfortunately have not been to an anglophone country for AGES!

Spiros Petrakis

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 103
  • VirtueMart Version: Always latest Stable
Re: Optional account creation not working :<
« Reply #1 on: September 16, 2012, 14:03:39 PM »
Hi ,

i had the same problem and i resolved it by putting first in the user fields the email field. When you have first form field one of the hidden fields (username or password) on guest checkout it causes an validation error.
Joomla templates and extensions development


  • Beginner
  • *
  • Posts: 2
Re: [Solved] Optional account creation not working :<
« Reply #2 on: August 04, 2015, 14:47:46 PM »
Man, years later, but still relevant. Anyways:

Oh my GOD, that did it. What a stupid bug. I guess that's why it's recommended to update your system everynow and then.

Thanks a lot, now it just works great!  :D