News:

You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

New pre subrelease VirtueMart 2.0.1 H

Started by Milbo, January 24, 2012, 22:44:41 PM

Previous topic - Next topic

JohnnyC

It depends on the template you are currently using and the existing support. Usually the templates need to be updated to work with newer versions.
I am using a free template (Shoplab) for VM2 from the two that I have found (I don't know if there are more at this tme). Only this template is updated to work with VM2.0.1... The other one is not!!  So check the template's developer page to see if there is a newer version


bunglehaze

#92
I can also confirm that the aforementioned issue with print view orders in the BE are still blank of data. I open up the page and there are no customer, item or payment details.

Ok folks, try this if you are having the same problem.

Uninstall the old version of VM and then reinstall - that has fixed my BE print view issue on orders where a simple overwrite seems to have failed. I have now done the same for my modules too as I have been having trouble with a few issues - hopefully this will solve those too but I will report back later.

bunglehaze

#93
Quote from: bunglehaze on February 02, 2012, 15:20:40 PM
Something else I just noticed since updating through to 2.0.1b which is a real pain: all of my products with custom fields are now saying call for price, I am looking through to see if their fields are still intact and try to find a reason why.

**Added**

Previously my cost price was set as £0.00 and each custom field assigned it's sales price which worked fine, if I wanted to set a base price and have the custom field add a specified amount I could do that also, now though I cannot set 0.00 in the price without it bringing up a call for price button instead of 0.00, I am using:

Custom Field Type:    Cart Variant

Milbo, I have installed the latest version to see the GUI option and I think our wires got crossed about the issue I was reporting.

In version 2.0.0 I setup all my custom fields for my products as cart variants, the reason for that was that the old attributes did not work from VM1. I sell (as an example) a light bulb which comes in 10 different options, all different prices and all the prices change so in my product I need to have a zero value for the item and then offer each variant as a set price.

Since 2.0.1 I cannot set a zero value for the item because the ask for price box comes up rather than just showing each of the custom fields listed as they were previously. The only way I can show prices for these custom fields is to add a price in the item value and then adjust the custom fields by a + or - value from that item price - ie if the product value is set to £52.99 and the second custom field price is £59.99 I have to set it as 7.00 in the custom field rather than the set price which is just an admin nightmare when the prices change as it means calculating each price again.

I cannot see a way to override the ask for price so when it does not show and the custom fields are in place it just displays them as a set price list. I need to have the option of a zero valued product to show the custom fields as prices and I am certain many others will use this method also.

Any ideas or suggestions?

***2nd problem found***

When setting discounts in this system also it would seem that the cart variant price is struck off completely in the checkout:

Ie - product base price = 0.10
discount is set so the product base overridden to = 0.09
I choose the product with a cart variant price of 53.29

with all the prices shown here is what I see in the product:
Price:
Base price: £53.39
Base price for variant: £53.39
Sales price: £0.09
Sales price without tax: £53.39
Discount: £53.30

*** Product option chosen in dropdown
Lamp Option = 150w 14000k double ended halide = £53.29 ***

So I:
add product to cart
and this is what I see:




[attachment cleanup by admin]

sydneyartschool

Just installed 2.0.1.e on test site

In Back End - Orders view shows no orders.  (I have data in the db for 67 orders)
In Front End - Checkout forces user to screen showing "please login first" after selecting "add/edit billing information"

bunglehaze

Quote from: sydneyartschool on February 06, 2012, 16:20:56 PM
Just installed 2.0.1.e on test site

In Back End - Orders view shows no orders.  (I have data in the db for 67 orders)
In Front End - Checkout forces user to screen showing "please login first" after selecting "add/edit billing information"

Did you try the post suggestion I made just above?

sydneyartschool

Hi Bunglehaze - yes I did an uninstall first.
Even went in and manually checked no remaining files.

Still no go!?

leveler

2.0.1d/2.0.1e - J1.7.3
Create a new category, and then create a new product. We are trying to give this product has just created a category - it's not on the list. All categories that were created in previous versions - are available for selection, but the categories created in the last two versions - not available.
These categories are published and can be seen in the list. They are also a search on the front page.

janis

hi

i get a loop when i order something.. and the order will not show up in the order list
http://forum.virtuemart.net/index.php?topic=97625.0

gr.
Files:  [url="http://dev.virtuemart.net/projects/virtuemart/files"]http://dev.virtuemart.net/projects/virtuemart/files[/url]

Updates:
[url="https://github.com/VirtueMart/virtuemart/commits/master"]https://github.com/VirtueMart/virtuemart/commits/master[/url]


love virtuemart when it's 10000% stable like in version 4.5 in the year 2015

murat

error in router.php in 2.0.1 vesrion. When i click checkout as guest it goes to page where i should register. if i use router.php from 2.0.0 vesrion everything is fine.

bunglehaze

Same issue with the orders in the backend as otherwise reported. print view now brings up order not found on release 2.0.1E

janis

any news about the ordering problem??

because i can't sell if that doesn't work..

gr.
Files:  [url="http://dev.virtuemart.net/projects/virtuemart/files"]http://dev.virtuemart.net/projects/virtuemart/files[/url]

Updates:
[url="https://github.com/VirtueMart/virtuemart/commits/master"]https://github.com/VirtueMart/virtuemart/commits/master[/url]


love virtuemart when it's 10000% stable like in version 4.5 in the year 2015

raunhar

#102
After upgrade from ver. 2 (experienced a problem after joomla upgrade to 2.5.1), the actegory is not showing all the products.
Currently there is only 1 category with two products. Both are published and showing at the backend.
But on the frontend, only one product is being displayed, and there is no sign of the second product.

I have setup shipping Method to be By weight, which is showing at backend (published), but when I try to checkout, the shipment method page shows Save/ Cancel, and nothing else. If I click on save, then I get redirected to home page.

PRO

Quote from: raunhar on February 08, 2012, 12:21:26 PM
After upgrade from ver. 2 (experienced a problem after joomla upgrade to 2.5.1), the actegory is not showing all the products.
Currently there is only 1 category with two products. Both are published and showing at the backend.
But on the frontend, only one product is being displayed, and there is no sign of the second product.

I have setup shipping Method to be By weight, which is showing at backend (published), but when I try to checkout, the shipment method page shows Save/ Cancel, and nothing else. If I click on save, then I get redirected to home page.


what do you have for "check stock" options, and do you display out fo stock products?

and also, did you enable multilanguage?

cas

I'm using VM2.0.1.e and Joomla 2.5.1. When checking out, PayPal gives the following error: Unable to process payment. Please contact the merchant as the shipping address provided by the merchant is invalid, and the merchant has requested that your order must be shipped to that address.