Importing Products from Virtuemart 1.1.4 to a fresh installation of VM2

Started by Biggreuda, November 12, 2011, 12:58:50 PM

Previous topic - Next topic


Hi there,

we have a technically pretty messed up old website, build in trial-and-error style.
So we decided to set up a completely new system and to import all data from the old one.
There are like 1600 Products in nearly 100 categories.

The new site's layout is nearly complete and I've set up half of the old categories and some of the products manually, for testing purposes.
I would like to import all products but set up the categories manually, because the content changed a little. I'm keeping the category IDs, of course.

I exported all vm-tables via phpmyadmin and imported them to the new database and now I'm transferring the product images.
Is there a way to keep the categories I've already set up, or do i have to update them again after the import?

Thanks in advance!  :)

P.S.: Should i post a link to the shop? It's in german... ;)
P.P.S.: Your spell check is cool! It wants to make "vegetables" out of "vm-tables"^^



Okay, thanks for that info! :)

I'm still copying the pictures. Why does it take so long to copy it from one folder of the same server to another (I'm using WS_FTP Pro)?
Well, I'm not really hoping for answers to my last question, since it's not directly a virtuemart problem, but any help would be appreciated anyway ;)


Copying the images just finished and I instantly tried hitting the "Start migration" Button.
After a few seconds, i got this:
QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
I tried it several times, each time the same result.
It doesn't help me much, do you have an idea what could cause it, or where i can find this "server error log"?  :(



Jepp, on the left, it says "2.0.0-RC-2M ".
I made an update just the day before I tried the import.


Do I have to put in anything at the migration-page in the backend?
I have honestly no clue what the "Server settings of max execution time" is.
And do I have to put in something for the default category/product layout or the storeowner id?

I just tried to start the migration again and got this:
        Found prior migration process, resume migration maxScriptTime 26 maxMemoryLimit 96
        Synchronized 410 media for product in directory images/stories/virtuemart/product/
        Worked on migration for 26.0742537975 seconds
        Migration finished

Still no new data shown in the backend, I will have a look at the database now, but I'm not really expecting to find anything new there :(
Wouldn't be fun to add all those products by hand again...

Whatever is happening, I'll try to hit the "Start migration" button as long as possible and hope that it's working somehow.
Didn't find anything in the database yet, but I got some error messages again:
        Found prior migration process, resume migration maxScriptTime 26 maxMemoryLimit 96
        Migrator store medias COM_VIRTUEMART_URL_NOT_VALID
        Synchronized 333 media for product in directory images/stories/virtuemart/product/
        Worked on migration for 26.0406610966 seconds
        Migration finished



Yes, I chose everything.
Now it says that i'm finished, but there is still one error message and there is nothing new showing up in the backend (couldn't find anything new except the media on the databases side):
Quote_productPorter Table 'd0124e20.jomkas_vm_product' doesn't exist SQL=SELECT * FROM jomkas_vm_product AS `p` LEFT JOIN jomkas_vm_product_price ON jomkas_vm_product_price.product_id = `p`.product_id LEFT JOIN jomkas_vm_product_mf_xref ON jomkas_vm_product_mf_xref.product_id = `p`.product_id LIMIT 0,2800

Regarding to the error message, the table can't exist, because the tables have different names.
Old table: jos_vm_product
New table: jomkas_virtuemart_products

Should I rename the imported tables and change the prefix to "jomkas"?
btw: maybe the earlier migration-problems where based on my hoster. They changed something, because I couldn't use vpn and after that the migration started to work, too.


YES, u can search and replace the file.

BACKUP before trying all this stuff though


Yes! It worked!
A few hundret error messages, but now the shop is filled with products! :D
I just had to change the prefix of the imported tables to the one in the new database.
The prices are alle messed up and it just copied all the categories I've already created, but it's still a huge step forward.
Thanks to you all! =)