Author Topic: SOLVED - Another database query  (Read 546 times)

Tikkiro

  • Jr. Member
  • **
  • Posts: 91
SOLVED - Another database query
« on: April 20, 2011, 16:24:09 pm »
Ok - situation in a nutshell is that I'm trying to rebuild my VM database from an earlier but possibly corrupted one (keeps throwing up an "Editor not found" or similar type msg and is unable to load any editor).  I figured if I started with a brand new database I could just import the keys separately to see which one caused the problem, but this isn't proving as easy as I'd expected.

I tried it on the Categories key but while the categories all show up fine in PHPMyAdmin, not one of them shows up in the shop.  If I then add in a new category that will show up in the former fine at the end of the list, but all the prior 8 still don't get picked up.  What's the reason for this if anyone knows?  Would I need to uninstall VM & install it with the keys already imported or would that just confuse the issue further?

I'm just desperate to hold off having to manually recode the entire shop once again - I'm disabled & typing for hours to undertake such a task takes me weeks sometimes, plus is quite a painful chore, so appreciate any help in figuring out a quicker solution perhaps?

Thanks for your patience.  :)
===========
Wanted to delete this as found the solution, so as I can't do that, I'll post my solution instead - others would have probably known to do this but ignorance of PHP isn't always bliss - all it required was to pull in the XRef keys also to complete the process - once I did that it worked fine.  And so is the editor so really hoping I can start to make some headway now on finishing the task without any further issues!