News:

Support the VirtueMart project and become a member

Main Menu

Can't enter in transaction key

Started by stanman1, June 03, 2010, 18:15:55 PM

Previous topic - Next topic

stanman1

I am trying to type the Authorize.Net Transaction Key into the payment module configuration of VirtueMart and it won't "take." The Current Transaction Key shows "(empty!)" and when I type my valid Joomla password into the field that asks for it the "Show/Change the Password/Transaction Key" form just reloads.

I know I am using the correct password and the form seems to be malfunctioning.

Can anybody help me?

integris1

Did you find the issue? I have the same problem with setting up eCheck
I was able to set up Credit Card properly however.
Joomla 1.1.59 VM 1.1.5

Stonedfury

No such thing as a stupid question, only a stupid answer. I won't ask if I know the answer or found it using the search as you suggested.

integris1

Searching the forums there seems to be quite a few people having a similar issue. Auth.net CC and echeck seems like a pretty basic feature to have an issue with.. I'm rather disappointed with this as I'm loosing a client over it.

Stonedfury

I have actually gotten this solved. It's pretty easy.

The password is your JOOMLA password.. I swear I messed that up a few times.

#1 Make sure you have an merchant account with Authorize.net

#2 Authorize.net API Login ID  (not your login name for the website)
This is your Authorize.Net API Login ID

Authorize.net Transaction Key    ---------     Ive done this a few times. It is fairly easy and again they will walk you through this. Give them a call. makes it easier than searching.

#3 Test runs dont work. For those that they do.. LUCKY.. Just set it up to go live.

#4 Don't turn on more than ONE credit card for authorize.net. You can set them up with different price groups. Shopper, Wholesale, Distributor, etc., but then turn them off. Do not enable them. The one that is enabled will use the groups from the others. (NO idea why it works like that)

#4 Make sure your host (should have mentioned sooner) has socks 443 open. As it is the default. Technically you can change this but eh. easier to comply. Most cpanel if not all are already set. cURL is not required per authorize.net.

Keep in mind. You can NOT have multiple credit card (authorize.net) processors enabled. Read above.

Hit me up if that doesnt help. Took a while but in the end it was plbcam (problem lies between chair and monitor)
No such thing as a stupid question, only a stupid answer. I won't ask if I know the answer or found it using the search as you suggested.

chasedoggy

Thank you for the quick response. I really appreciate it.

I've tried this with the SuperUser and it's not doing me any good. Could it be something else? I definitely am using the Super User. I have multiple Super User accounts but I am using the original super user account that was created when Joomla! was installed.

Does anyone know another way to upload the transaction key? Can I put it directly in the db?

PRO



idgafra


nflmerch

Quote from: idgafra on November 24, 2010, 17:50:09 PM
I couldn't get it to work in FireFox so I switched to Safari and it worked.

Same here, I couldn't get it to work in IE, but it works great in google Chrome

PRO

Quote from: werod79 on October 12, 2011, 19:27:27 PM
I am trying to fix credit card problem , I figure out that credit card method is related to   Authorize.Net  , I don't have login information to solve my problem , I don't have the password and I don't have email address to reset the password ( somebody else create that account ) , I am trying to call them more than 1 week just to reset the password but no help.

I know  Login ID and  Transaction Key (Authorize.net).
Does  anyone know how I can login to my account ?

Or can I use another payment method for credit card ? (easier and cheaper )

http://kb.siteground.com/article/How_to_reset_my_Joomla_administrator_password.html

trisect

I had to create a new super admin account and use that instead of my original one. For some reason, by using the new one I'm able to reset the transaction key fine.

Quick Reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
7+4+3:
Shortcuts: ALT+S post or ALT+P preview