News:

You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

Error in registration form

Started by yobokkie, October 08, 2015, 16:11:11 PM

Previous topic - Next topic

lindapowers

Hi guys, the fields are still disappearing with existing username, dont know if some of the fixes here were applied already but at least in latest vm 3.0.12 is still happening.
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -

Milbo

The fields are not dissapearing you mean the input, for me it works.
Should I fix your bug, please support the VirtueMart project and become a [url=http://extensions.virtuemart.net/support/virtuemart-supporter-membership-detail]member[/url]
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

lindapowers

#17
Quote from: Milbo on November 16, 2015, 01:04:07 AM
The fields are not dissapearing you mean the input, for me it works.


Hi Max I tested again in your demo http://demo.virtuemart.net/account/edit using "demo" as username and the input of the fields dissapeared below the message "Save failed with the following error: User name in use".

I checked and 3.0.12 is installed there.

Regards
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -

Milbo

Ah yes, because you opened the account editing window. Hmm. I wrote it for the cart editing address view. Hmm, then I need to add there, that it becomes stored in the cart also, which makes sense.

When you try here, it should work http://demo.virtuemart.net/account/editaddresscartBT
Should I fix your bug, please support the VirtueMart project and become a [url=http://extensions.virtuemart.net/support/virtuemart-supporter-membership-detail]member[/url]
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

lindapowers

Quote from: Milbo on November 16, 2015, 10:11:16 AM
Ah yes, because you opened the account editing window. Hmm. I wrote it for the cart editing address view. Hmm, then I need to add there, that it becomes stored in the cart also, which makes sense.

When you try here, it should work http://demo.virtuemart.net/account/editaddresscartBT

That would be great yes, still many customers try to register from there directly.

Regards
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -

lindapowers

#20
Hi, this still happens in 3.0.18.1/2

If you enter an existing username (i.e demo) in http://demo.virtuemart.net/account/edit the input of the fields get reset and users have to enter all data again.
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -

lindapowers

This still happens in 3.0.18.7

If you enter an existing username (i.e demo) in http://demo.virtuemart.net/account/edit the input of the fields get reset and users have to enter all data again.

No need to tell how many customers all the shops are loosing due to this.

We have surrender and redirected register to joomla's default register where the issue does not happen.
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -

jenkinhill

That does not happen for me with VM3.0.18.7  Blue Corvus 9410  on J3.6.5 using Firefox 50.1 with default VM templates,  I see the error message, eg Save failed with the following error: This email address is already registered. and the fields remain filled in.
Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

lindapowers

Quote from: jenkinhill on January 06, 2017, 15:53:07 PM
That does not happen for me with VM3.0.18.7  Blue Corvus 9410  on J3.6.5 using Firefox 50.1 with default VM templates,  I see the error message, eg Save failed with the following error: This email address is already registered. and the fields remain filled in.

You sure about that?

In all my tests the fields get empty once that message appears with beez template.

I just tested in Firefox, Chrome, IE and even microsoft Edge and happened the same.

Can you provide a link?

I tried testing in VM site too http://demo.virtuemart.net/account/edit with username demo to replicate the error but clicking "register" leads to a 404.

What VM link are you setting for register? cause im talking about the one posted to VM site.

Regards
[url="https://www.lluislaw.com"]https://www.lluislaw.com[/url] -