Author Topic: Installation error vmError: Could not find VirtueMart submenues, please install  (Read 4709 times)

goraelec

  • Beginner
  • *
  • Posts: 2
  • A beginner
Hello. I'm trying to install VirtueMart 3.0.14 on joomla 3.5.1, but I'm getting error "vmError: Could not find VirtueMart submenues, please install VirtueMart again"
and "UPDATE SERVER NOT FOUND IN XML FILE:/administrator/components/com_virtuemart/virtuemart.xml"

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28473
  • Always on vacation
    • Jenkin Hill Internet
You should use VirtueMart 3.0.16 with Joomla 3.5.1  Get it from here:  http://dev.virtuemart.net/projects/virtuemart/files

Install instructions (apply to VM2 and 3)  http://docs.virtuemart.net/tutorials/30-installation-migration-upgrade-vm-2/80-installation-of-virtuemart-2.html

You can ignore the update server message if you see it, as that is not required for installation.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 4.0.12 10777  J 3.10.11 PHP 7.4.30

goraelec

  • Beginner
  • *
  • Posts: 2
  • A beginner
I had the same with 3.0.16

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10701
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
r u installing fresh or updating? Explain fully what your trying to do

This message only comes if VM is already installed (com_virtuemart menu entries exist) and there are some menu problems

also afaik it doesn't stop the installation

look at administrator\components\com_virtuemart\install\script.virtuemart.php to see what its doing
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

mickey3k

  • Beginner
  • *
  • Posts: 9
Hi,

I get the exact same error and cannot find any solution to it.
I tried installing VM 3.0.16 on Joomla 3.5.1 (PHP 5.6) with the Joomla installer and get the same messages "vmError: Could not find VirtueMart submenues" and Update Server not found. I am pretty sure that I uninstalled VM once, so it is not a fresh installation (but I installed and re-installed so many times now that I am not 100% sure any more ;)).

I had VM running on this host/Joomla version before but had to re-set up the site completely after it has been hacked. So it is rather no provider problem.
I tried with older VM versions, with version 3.0.17, set the PHP version down, checked the folder/file permissions with Akeeba Admin Tools, but nothing helped..

There must be more information to this error.. Please if anyone has any tips, I'd be glad to hear.

I would try installing manually, but I don't really know how. Can someone tell me how to manually install VM or post a tutorial? Simply uploading the folders is not everything, I guess...

It would be really great to get some hints on how to solve this problem because it makes using VM impossible..

Thanks!
Michael

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10531
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
The problem is the reinstalling. I fear your vm menues are out of order. We advice not to reinstall, it creates a lot problems. Better is to update.

use phpmyadmin or similar and open your _menu table, delete all entries with "com-virtuemart" in the path and use the tableupdater to get the menues back.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/