News:

Looking for documentation? Take a look on our wiki

Main Menu

Blank Page when trying to access product data

Started by hartleyheaton, February 17, 2014, 18:05:17 PM

Previous topic - Next topic

hartleyheaton

I have created a site on my local machine under WAMP and have no problems, all working fine.

I have transferred the site onto a Linux server and now although the front end of the site is working I can't edit any of the products in Virtumart I just get a completely blank page. I have tried turning on debug in both Virtuemart and Joomla but get no information.

I have checked the various versions between WAMP and the Linux server and apart from very minor version numbers PHP, MYSQL and APACHE are the same. Virtuemart is version 2.0.26d.

I assume that there is a conflict of something but do not know what. If anyone has any advice on how to find out please let me know.

Thanks

hartleyheaton

I have found the answer so thought I would detail how I solved this.

First off so that I was able to get an error message I changed the Error Reporting level, in Global Configuration > Server, to Development. This then reported a memory allocation problem.

This had me confused as I had already checked the PHP memory setting in the ini file and this was set to 32M yet the error report was showing that it could not allocate memory over 24M. I later discovered that there is a .user file with Joomla 2.5, which overrides the PHP settings, and the memory limit was set to 24M in this file.

I changed the .user file to 32M and it is now working fine.

wicko

I too have this issue but don't know where this default joomla php file is. Can you please give root to this file and explain what you actually did to correct it.

Many thanks

Wicko
Designing and maintaining Joomla websites since 2007

Milbo

The only thing we do is to ensureMemoryLimit.

that means we check sometimes for example for pdfs or thumbnailing if enough RAM is available, if not we try to set a setting which usually works.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

wicko

Designing and maintaining Joomla websites since 2007

hartleyheaton

The .user.ini file is in the top level of the site.  There is a line in it "memory_limit = 32M". This was set to 24M in my installation I just changed it to 32M.

The installation of Joomla was taken directly from joomla.org so I think that this may be a problem that will effect a few people. I understood that the standard for PHP is 32M but as I have said earlier the .user.ini file contents override the PHP settings.

This is the first time that I have come this problem so took some time sorting it out but you learn something new every day.

jenkinhill

A .use.ini file is not part of Joomla or included in its installation, so I guess it included as part of your localhost. The file is like an override setting for system php.ini  which does not get altered when, for example, the server Apache/PHP is updated. It is used only by only by the CGI/FastCGI SAPI. See http://www.php.net/manual/en/configuration.file.per-user.php
Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum