Author Topic: Upgrade issue from 2.0.20b to 2.0.22a  (Read 7681 times)

Sadicer

  • Beginner
  • *
  • Posts: 36
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #15 on: August 09, 2013, 11:12:27 am »
thank you so much! it was just a matter of setting the system language. Thanks also now inform the comunity Virtuemart Italy.
PS: I can now change the admin password?  :-*

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #16 on: August 09, 2013, 20:15:14 pm »
thank you so much! it was just a matter of setting the system language. Thanks also now inform the comunity Virtuemart Italy.
PS: I can now change the admin password?  :-*

yes

Sadicer

  • Beginner
  • *
  • Posts: 36
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #17 on: August 09, 2013, 20:46:18 pm »
ok  ;)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #18 on: August 10, 2013, 15:49:15 pm »
VM2.0.22a has a fallback now for this. So even you entered everything into the english tables, and changed your site language to italian, it should now work with configuring english in the vm config. => Uses then for all languages the english tables.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Sadicer

  • Beginner
  • *
  • Posts: 36
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #19 on: August 10, 2013, 19:39:35 pm »
 :o I'm sorry but I did not understand some technical words, help me with a translation software, which is the meaning of the word "fallback."?

I have a question, if I do not use setting "all languages​​", a user English if you look at my fee, will look at the empty cart or look at the products with the description in Italian language? :-\

esedic

  • Jr. Member
  • **
  • Posts: 66
    • Spletodrom.com
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #20 on: October 09, 2013, 16:16:06 pm »
I still have this error when using default joomla SEF urls, but only if I try to open a product details page.
I have two languages in Joomla: English and Slovenian (sl-SI), default language is Slovenian.
I have all data in my language VM database tables (#_virtuemart_categories_sl_si , #_virtuemart_manufacturers_sl_si, #_virtuemart_products_sl_si, etc).
In VM configuration in Languages Settings > Multilingual shop I have Slovenian (Slovenija) language selected and "Use english as fallback for untranslated strings" checked.
I'm not using English language though.

I've seen these lines in components/com_virtuemart/views/category/view.html.php:

Code: [Select]
if(empty($category->slug)){
vmInfo(JText::_('COM_VIRTUEMART_CAT_NOT_FOUND'));
}

If I dump $category->slug without SEF urls I get correct category slug from database (it's not empty), so I don't understand why this error is thrown.

I'm using VM v2.0.22c on Joomla 2.5.14 , I will update to VM 2.0.24 this week.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28263
  • Always on vacation
    • Jenkin Hill Internet
Re: Upgrade issue from 2.0.20b to 2.0.22a
« Reply #21 on: October 09, 2013, 17:17:41 pm »
I will update to VM 2.0.24 this week.

Yes, do that. It has some multi-language fixes.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14