Author Topic: =?utf-8?Q? in order mail  (Read 2774 times)

travelbaba

  • Beginner
  • *
  • Posts: 26
=?utf-8?Q? in order mail
« on: March 31, 2015, 09:15:45 am »
Hello,

this argoument was already mentioned, but the solution offered doesn't work for me.
I have Joomla! 3.4.1 and VirtueMart 3.0.6, befor the last update was working everything smooth.

But noww hen a do an order the title of the mail is like this:

=?utf-8?Q?[1ef2023], _ordine_confermato_da_TIME_OUT_SRL, __Timeout_Timeout, ?=   totale 37, 00 €

I've checked the last italian translation, i've checked the collation of database UTF-8 Unicode (utf8)

If someone can help me would be really appreciated.

Thanks!

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3717
  • using Matomo instead of Google Analytics
Re: =?utf-8?Q? in order mail
« Reply #1 on: April 01, 2015, 20:40:47 pm »
Just checked the italian language file. That one looks correct for me. What you see in the header is the first part of the string in this line: COM_VIRTUEMART_MAIL_SUBJ_SHOPPER_C="[%3$s], Ordine confermato da %1$s, per un totale di %2$s"
But I have no idea why you get TIME_OUT_SRL, __Timeout_Timeout in the email subject. The raw header in an order confirmation email would normally look like this:
Subject: =?utf-8?Q?[04900264],_Confirmed_order_by__Customer_Name,_total_37,00_?=  =?utf-8?Q?=E2=82=AC?=
There is an italian company with the name TIME OUT SRL, so the 'Customer_Name' could be correct. But as I said, no idea what could cause the timeout in the subject line.

In this post: http://forum.virtuemart.net/index.php?topic=128942.msg443449#msg443449 you mentioned php 3.4.xx. Is that a typo?
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

travelbaba

  • Beginner
  • *
  • Posts: 26
Re: =?utf-8?Q? in order mail
« Reply #2 on: April 05, 2015, 09:35:07 am »
Problem solved, It's imac with yosemite that don't encode header utf8 !!!!
In PC the header lloks fine!

Thanks