You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

VM search module and encoding problem.

Started by syntalk, May 29, 2013, 21:22:31 PM

Previous topic - Next topic


I wasn't sure should I post it here or in the modules section.
I have a VM search module and site in polish and english (english is disabled at the moment). When I put the polish characters i get strange stuff like in example if I put "ó" I get "C3B3" in return so if I search for "ogórek" it seeks for "ogC3B3rek" and obviously finds nothing .
All rest is working fine and tried Joomla search module and worked fine. Also tried on Beez template with same problem in result.
Using native Joomla and VM translation.

J 2.5.11 + PL
VM 2.0.18c + PL

Any ideas are welcome.


Please check if your database including all tables are set to collation utf8_general_ci.
Non-English Shops: Are your language files up to date?



I don't know if this works, but perhaps it helps if you would set your polish language product table or at least it's name, short description and description columns to utf8_polish_ci collation in the database.
Non-English Shops: Are your language files up to date?


Cheers again but still the same.
I wonder because I found in my phpMyAdmin this:
MySQL charset: UTF-8 Unicode (utf8)
MySQL connection collation: UTF-8_general_ci(utf8)
Should I ask my hosting provider to change MySQL charset: UTF-8 Unicode (utf8) to UTF-8_general_ci(utf8)?
But then how it comes that joomla search form is working fine?


Another idea (not tested!) - If I look at the Joomla language files, they come with a 'local' attribute in the xml file. If I understand that correctly, these are supplied to make the language files work on different operating systems. An example:

<name>Polish (PL)</name>
<locale>pl-PL.utf8, pl_PL.UTF8, pl_PL.utf8, pl_PL.UTF-8, pl_PL.utf-8, polish_POLISH.UTF8, polish_POLISH.utf8, pl.UTF8, polish.UTF8, polish-pl.UTF8, PL.UTF8, polish.utf8, polish-pl.utf8, PL.utf8, pl_PL, polish_POLISH, pl, polish, polish-pl, PL, poland, Poland, pl_PL.ISO8859-2, polish_POLISH.ISO8859-2, pl.ISO8859-2, polish.ISO8859-2 polish-pl.ISO8859-2, PL.ISO8859-2, pl_PL.iso88592, polish_POLISH.iso88592, pl.iso88592, polish.iso88592, polish-pl.iso88592, PL.iso88592</locale>

Maybe it makes a difference if you copy this into the VirtueMart xml file for the polish language and install the language pack again afterwards.
Non-English Shops: Are your language files up to date?


Thanks jjk,

Didn't work unfortunately.
Problem seems to be related to the server. I replicated the store locally on xammp and it works fine. Only wonder why native joomla search and everything else is ok?
Will do few more tests.