Author Topic: Division by Zero on com_virtuemart/models/product.php [SOLVED]  (Read 17806 times)

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #15 on: July 03, 2012, 21:14:25 pm »
The issue has been resolved to version 2.0.8b. So there is no need to change that lines.
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

CreativeDesigns

  • Jr. Member
  • **
  • Posts: 219
    • Creative Designs Studio
  • Skype Name: creative.designs.za
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #16 on: July 04, 2012, 15:40:48 pm »
I had the same problem with the error "/administrator/components/com_virtuemart/models/product.php on line 516"

I went into my category and changed the number of products per line to 5, and when I refreshed my homepage, no products are showing? Why is this happening?

cecilia2330

  • Beginner
  • *
  • Posts: 15
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #17 on: July 05, 2012, 17:42:06 pm »
Thanks!
I update to v.2.0.8b.
It dont have any error message on the webpage
But when I click " next" button , it cant show next page , still the same (first page)
Why will have this problem???

cecilia2330

  • Beginner
  • *
  • Posts: 15
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #18 on: July 05, 2012, 18:47:43 pm »
I update to V 2.0.8c , but the problem still cant solved
While I click "sort by" items (such as change sort by product id to product description) , than click next button , it work perfect

Is it a bug?
I try many time but the problem still exist....
anyone can help me

BaidareW

  • Jr. Member
  • **
  • Posts: 111
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #19 on: July 05, 2012, 21:46:55 pm »
In 2.0.8c products per category view not working as expected. Showing 8 instead of XX.

cecilia2330

  • Beginner
  • *
  • Posts: 15
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #20 on: July 06, 2012, 17:40:12 pm »
In 2.0.8c products per category view not working as expected. Showing 8 instead of XX.
sorry BaidareW..can you explain more detail???
Is it mean I cant fix this problem?
But I work fine when I use 2.06 version
Can I downgrade to 2.06......?

cecilia2330

  • Beginner
  • *
  • Posts: 15
Re: Division by Zero on com_virtuemart/models/product.php [SOLVED]
« Reply #21 on: July 06, 2012, 17:45:19 pm »
I find that when I click next button , it show the link " http://www.premiumyd.com/main/index.php/zh/2012-05-20-17-25-24/travel?start=12 "

If i change the "sort by " button , when I click next button , it shows the link "
http://www.premiumyd.com/main/index.php/zh/2012-05-20-17-25-24/travel/by,product_sku/results,13-12?language=zh-TW"

Can anyone tell me how to fix it...thx a lot