Author Topic: Products filter 'published' not working  (Read 175 times)

2cool

  • Jr. Member
  • **
  • Posts: 289
Products filter 'published' not working
« on: January 23, 2023, 11:42:57 am »
I just noticed a little issue in VirtueMart 3.8.8
While editing and filtering products I use "Search Product' for 'Published' products only.
After editing a product I hit 'Save & Close' and return to product list...
But now also the unpublished products are listed?? While the filter option itself is still on 'Published'

Any suggestions for to fix this?

Using Joomla! 3.10.11 and  php 7.4.30

Regards,
Pas

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28458
  • Always on vacation
    • Jenkin Hill Internet
Re: Products filter 'published' not working
« Reply #1 on: January 23, 2023, 11:45:35 am »
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 4.0.12 10777  J 3.10.11 PHP 7.4.30

2cool

  • Jr. Member
  • **
  • Posts: 289
Re: Products filter 'published' not working
« Reply #2 on: January 23, 2023, 11:59:27 am »
Hi Kelvyn,
Thanks but not tried yet with version 4...
Is this an 'easy' update without lots of issues in cobination with joomla 3.10.11?
And this filter 'bug' is no issue anymore.

Regards,
Pas

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28458
  • Always on vacation
    • Jenkin Hill Internet
Re: Products filter 'published' not working
« Reply #3 on: January 23, 2023, 12:07:53 pm »
I have not seen your bug, but have not specifically looked for it. As VM 3.8.8 is 2 years old it probably is time to consider updating. Of course, try it on a backup copy of your live site first as there are likely to be changes in configuration, as well as the revised admin template.

I use VM 4.0.12 10777 with J3.10.11
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 4.0.12 10777  J 3.10.11 PHP 7.4.30

2cool

  • Jr. Member
  • **
  • Posts: 289
Re: Products filter 'published' not working
« Reply #4 on: January 23, 2023, 12:10:45 pm »
Thanks,
I'll backup and test local first to see if all works ok and the filter will be fixed.
Thanks,
Pas

2cool

  • Jr. Member
  • **
  • Posts: 289
Re: Products filter 'published' not working
« Reply #5 on: January 24, 2023, 14:37:13 pm »
Yes, filter problem solved with latest VirtueMart 4.0.12

But on front end filtering I get this error "Call to a member function displayMediaThumb() on null"
See this in other posts (http://forum.virtuemart.net/index.php?topic=143968.0) but not sure if this still is an issue?

Regards,
Pas

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28458
  • Always on vacation
    • Jenkin Hill Internet
Re: Products filter 'published' not working
« Reply #6 on: January 24, 2023, 15:28:00 pm »
I have only seen that error with a template issue, although also reported when using multiple product images.

Best to provide a trace for the error.  In Joomla Global Configuration. Set "Error Reporting" as "Maximum" and enable the “Debugging" option.

Go to VirtueMart Configuration and set PHP Development mode for “all”.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 4.0.12 10777  J 3.10.11 PHP 7.4.30

2cool

  • Jr. Member
  • **
  • Posts: 289
Re: Products filter 'published' not working
« Reply #7 on: January 24, 2023, 16:11:43 pm »
I think it's plugin (customfilter) related....maybe i'll create a new post.

    Call to a member function displayMediaThumb() on null

Naar de startpagina
Call stack
#    Function    Location
1    ()    JROOT/templates/vp_merchant/layouts/mx/html/com_virtuemart/sublayouts/products.php:100
2    require()    JROOT/templates/vp_merchant/html/com_virtuemart/sublayouts/products.php:19
3    include()    JROOT/components/com_virtuemart/helpers/shopfunctionsf.php:567
4    shopFunctionsF::renderVmSubLayout()    JROOT/templates/vp_merchant/layouts/mx/html/com_virtuemart/category/default.php:226
5    require()    JROOT/templates/vp_merchant/html/com_virtuemart/category/default.php:19
6    include()    JROOT/components/com_customfilters/include/cfview.php:119
7    cfView->loadTemplate()    JROOT/components/com_customfilters/include/cfview.php:44
8    cfView->display()    JROOT/components/com_customfilters/views/products/view.html.php:180
9    CustomfiltersViewProducts->display()    JROOT/libraries/src/MVC/Controller/BaseController.php:664
10    Joomla\CMS\MVC\Controller\BaseController->display()    JROOT/components/com_customfilters/controller.php:47
11    CustomfiltersController->display()    JROOT/libraries/src/MVC/Controller/BaseController.php:702
12    Joomla\CMS\MVC\Controller\BaseController->execute()    JROOT/components/com_customfilters/customfilters.php:41
13    require_once()    JROOT/libraries/src/Component/ComponentHelper.php:402
14    Joomla\CMS\Component\ComponentHelper::executeComponent()    JROOT/libraries/src/Component/ComponentHelper.php:377
15    Joomla\CMS\Component\ComponentHelper::renderComponent()    JROOT/libraries/src/Application/SiteApplication.php:194
16    Joomla\CMS\Application\SiteApplication->dispatch()    JROOT/libraries/src/Application/SiteApplication.php:233
17    Joomla\CMS\Application\SiteApplication->doExecute()    JROOT/libraries/src/Application/CMSApplication.php:225
18    Joomla\CMS\Application\CMSApplication->execute()    JROOT/index.php:49

Regards,
Pas

Jumbo!

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 871
  • Full-stack Web Developer
    • www.virtueplanet.com
  • VirtueMart Version: Always the latest
Re: Products filter 'published' not working
« Reply #8 on: January 24, 2023, 16:37:26 pm »
It is a problem with the 3rd party Custom Filter extension you are using on your site. It is not the standard VirtueMart category product listing page but a page/view of the custom filter extension, which uses its own SQL queries.

Create a standard VirtueMart category page menu item for the same category, and it will work just fine.