Author Topic: Message 1 vmdebug Doing base64_decode  (Read 1457 times)

titolin10

  • Jr. Member
  • **
  • Posts: 80
  • A beginner
Message 1 vmdebug Doing base64_decode
« on: April 13, 2020, 19:26:35 pm »
Hello everyone,

Hopefully, I'm posting in the right forum.

Firstly:
Joomla 3.9.16
VM 3.6.10
PHP 7.3

The issue that I'm facing might be related to the issue that had discussed here:
http://forum.virtuemart.net/index.php?topic=143968.0

I was getting the same error message.

"0 - Call to a member function get() on null"

This error was appearing when updating user info or even when I try to reset a forgotten password or username for (The Test registered user) from the front end.

After applying the patch from Milbo then all the debug errors disappeared except that I got this message:
Warning
Assign the component VirtueMart to a menu item
It sticks on the registration page and some other pages including the cart page (but sometimes it disappear from the cart page by itself lol). I already tried all the possible ways to solve it such as creating a menu item for the top-level category layout and the deprecated front page and by creating a menu item for the user maintenance page.

After that, I enabled (Enable debugging of methods) in shop advanced settings and I got this on the cart page and some other pages:
Message
1 vmdebug Doing base64_decode �"R�Z���3?aW �n�Q���

Not only the above but I can say that the issues made the reset password and username useless since the pages redirect me to the user registration page (Your account details) and there is no reset email received in inbox nor spam. for making sure I tried using different users and different emails and reset data message never arrived. But when register new users the email will arrive in inbox normally since the SMTP server is working properly with the needed authentication.

For testing the issues that I described you can see my live website here:

 https://b it.ly/2Xy35Nm

(remove the space in "bit" word).



If the issue was describing a confirmed or potential bug and there is a solution then I would be happy to know it. If it's not a bug and something wrong with the settings then I'm sorry for posting in this forum's category.

Thank you in advance

titolin10

  • Jr. Member
  • **
  • Posts: 80
  • A beginner
Re: Message 1 vmdebug Doing base64_decode
« Reply #1 on: April 14, 2020, 11:28:34 am »
Hi,

Here is an update:

The issue seems to be from the VM Framework Loader during Plugin Updates.

After I disabled Redirect Joomla to VirtueMart registration in the plugin then all the issues that I have mentioned are solved now.


Also, the plugin was causing an issue with PayPal express checkout. when redirecting to Joomla registration was enabled the user was able to checkout and go to Paypal even the cart is empty and PayPal was returning error messages. Now after switching off the redirect in the plugin, the cart is working normally and the user now can see the message "There are no products in your cart." in case if the cart is empty instead of getting an error message from PayPal.

Thanks


GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10302
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Message 1 vmdebug Doing base64_decode
« Reply #2 on: April 14, 2020, 17:04:01 pm »
r u sure u have the latest VM Framework Loader during Plugin Updates?

I remember these problems with lost password etc when the plugin was first introduced but they problems were fixed
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

titolin10

  • Jr. Member
  • **
  • Posts: 80
  • A beginner
Re: Message 1 vmdebug Doing base64_decode
« Reply #3 on: April 16, 2020, 16:46:17 pm »
Hello GJC

Virtuemart 3.6.10 is the first time to be installed on the website (Just since less than 2 weeks ago). There is no Virtuemart on the website before. So I'm sure it's the latest version except if there is a new build that I didn't consider.

My report is about the version 3.6.10 with its own plugins without any direct change from me.

Regards