Author Topic: Wrong VM links at Joomla menu assigned to VM 2 Component  (Read 2063 times)

TechnoMage

  • Beginner
  • *
  • Posts: 31
Wrong VM links at Joomla menu assigned to VM 2 Component
« on: March 19, 2012, 20:37:16 pm »
Hi,

I have downloaded and installed a swMenuFree component for my Joomla 1.5.25 and assigned the menu to the virtuemart component and all top categories, however all of my menu links look like this for example:

component/virtuemart/?page=shop.browse&category_id=270.

After clicking on them the main VM 2 page is beeing loaded every time. If I enable the AIO Category those links are just working fine.

Am I doing something wrong or is it some kind of bug? The links do not change if I make any modification in the SEO settings. It would be also nice if someone could explain from where (which php file) are these links coming from.

Cya

TechnoMage

  • Beginner
  • *
  • Posts: 31
Re: Wrong VM links at Joomla menu assigned to VM 2 Component
« Reply #1 on: April 04, 2012, 18:35:39 pm »
Hi,

I have realised that this url structure is coming from the menu extension and therefore it has to be updated there to be virtuemart 2.0 compatible.

Cya

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28382
  • Always on vacation
    • Jenkin Hill Internet
Re: Wrong VM links at Joomla menu assigned to VM 2 Component
« Reply #2 on: April 05, 2012, 18:42:21 pm »
Others have reported javascript compatibility issues with swmenu, too, preventing add to cart from functioning.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart  4.0.2 10661 on Joomla 3.10.9 PHP 7.4.29