Looking for documentation? Take a look on our wiki

Main Menu

Can't enter to virtuemart's administration page

Started by SlavaVlasov, February 23, 2012, 09:13:39 AM

Previous topic - Next topic


I have a problem:
I installed Virtuemart 2.0 on Joomla 1.7. At first it worked fine, but then I needed to restore the site from backups (backups I'll making by Akeeba Backup and recovering by Akeeba Kickstart).

After recovery, I can not enter the Virtuemart's admin panel: When I click the "Components > Virtuemart", I have shown the error:
Fatal error: Call to undefined method JLanguage::getBackwardLang() in /var/www/u2370076/public_html/ on line 78

I've read on other forums that this error can only occur when attempting to install older versions of virtuemart to new versions of Joomla (eg Virtuemart 1.x.x on  Joomla 1.6/1.7), but since I installed VM 2.0 on Joomla 1.7 this error should not be. So I was confused.

What is the solution in this situation?


The situation is solved! When I restored the site from backup, expansion Akeeba backup, and backup-archive will been located in the my "backup" folder. Unpack the files from the archive was made precisely in this folder. And when I tried to move the files from the "backup" folder in the root of the site, I have something there is not successfully moved.

Then I repeated the restore from backup and went to the site as follows:
Restored from backup site, and in addition Virtuemart worked fine. After that, I (directly on the server) will compressed the contents of the folder "backup" to the archive (NOT by akeeba backup). At the root of the site, I deleted everything except the "cgi-bin". Then I moved to the root my archive and then decompressed it.

All working fine now.