Author Topic: Enabling multi-x disables super admin to add taxes' rules  (Read 3006 times)

cmatte

  • Beginner
  • *
  • Posts: 40
Enabling multi-x disables super admin to add taxes' rules
« on: December 24, 2011, 15:49:22 pm »
As the title says, as soon as I, super admin, enable the multi-vendor option, I get a
Code: [Select]
403 - Error.
Forbidden for non vendors

Back to control panel
error.
Is it easily solvable?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10144
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Enabling multi-x disables super admin to add taxes' rules
« Reply #1 on: December 25, 2011, 11:44:00 am »
Make your superuser to a vendor
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

cmatte

  • Beginner
  • *
  • Posts: 40
Re: Enabling multi-x disables super admin to add taxes' rules
« Reply #2 on: December 25, 2011, 12:19:17 pm »
There's something weird here with permissions, I don't know why but I have this feeling since the first configuration.
I am a vendor, too, I thought I had to enable me to be a vendor in fact. But for example I'm disallowed to do some base things, taxes' "add" menu gives that error if I enable multi-x and I can't delete orders. Also I attach a screenshot of the possible problem: I am listed in the group "admin / (deprecated)", when I open my info I see group saying "select an option", and if I click, choose super user, save, it's done but the value stays admin / (deprecated) in the previous screen and "select an option" in the edit screen.
In J! I am the only "founder" and I am in the group "super users". I didn't modify anything, super users do have all the default acl permissions, in /administrator/index.php?option=com_config I see super users have the "Super user: allowed" option and all the others are inherited and as expected in the right column I see a list full of "Allowed (super administrator".

p.s. Merry Christmas  ;) ;)

---edit---
I think I've just found something that isn't working as expected in clients/vendors data.
I tried modifying my user data adding a name of the shop, writing ND everywhere, since messages was saying I need to input a name. Clicking save it saved but opening my page again shows no data in the vendor info. So I wrote there ND everywhere, again. Clicking save it said ND was already in the _virtuemart_vendors and added a casual number at the end. Now it saved for real, data are there, with the casual number. Opening the _virtuemart_vendors db I see there's a line with the "ND" I wanted that wasn't set and isn't anymore settable now!

[attachment cleanup by admin]