Author Topic: Notice: We are unable to ship via USPS at this time. System Error. - Domestic  (Read 8808 times)

Nathan

  • Jr. Member
  • **
  • Posts: 78
On domestic order I get this error:
Notice: We are unable to ship via USPS at this time. System Error.

When I go to choose what kind of shipping.

The only choices given are DHL

I think USPS must have changed something.  This works fine with International orders (canada) but not with USA orders.  I have USPS 5.2011.02.10, Virtuemart 1.1.9,

here is debug mode:

Please select a Shipping Method!

uspsv5::__construct() - Starting module version 5.2011.02.10
uspsv5::list_rates() - Starting
Shipment::addPackage() Adding a new bundled package
Shipment::addPackage() - Package Number: 1
Shipment::addPackage() - Package is Bundled
Shipment::addPackage() - Maxweight: 70
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::addItem() - WARNING - product dimensions assumed to be INCHES
Package::query_rates() - Querying for Source: US/49770 , Destination: US/54884, Weight: 0.54825, Value: 44
uspsv5::get_rates_array() - Calculating domestic shipping.

XML Post:

http://Production.ShippingAPIs.com/ShippingAPI.dll?API=RateV4&XML=<RateV4Request USERID="XXXXXXX" ><Revision /><Package ID="0"><Service>All</Service><ZipOrigination>49770</ZipOrigination><ZipDestination>54884</ZipDestination><Pounds>0</Pounds><Ounces>9</Ounces><Container /><Size>REGULAR</Size><Machinable>FALSE</Machinable></Package></RateV4Request>

XML Result

<?xml version="1.0"?>
<RateV4Response><Package ID="0"><Error><Number>-2147219401</Number><Source>;clsRateV4.CreateAllPostage-;RateEngineV4.ProcessRequest</Source><Description> Error Information: The Destination ZIP Code you have entered is invalid.</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package></RateV4Response>

Shipper   Shipping Rate   Price
   DHL   World_1 > 4kg   $41.66
   DHL   World_2 > 4kg   $50.53
Package::query_rates() - Rate query returned null results.
Shipment::populate() - query_rates() failed.
uspsv5::list_rates() - shipment->populate() failed!
Notice: We are unable to ship via USPS at this time. System Error.

On international (canada orders) this works fine???  Any thoughts?
Any thoughts?

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
I edited your post to remove your API user name.  Never post that to a public forum.  Also, in the future post all USPSv5 issues into the USPSv5 thread, as I receive email notifications of those posts.

The error message speaks for itself...the API thinks that the ZIP code is invalid.  If it is indeed a valid ZIP, you'll need to contact USPS and ask them why it is returning an error.  There is really nothing we can do on the module/VirtueMart end about that.

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Nathan

  • Jr. Member
  • **
  • Posts: 78
THanks Reggie.  Anyway to send that error to the user when they are checking out?

Nathan

  • Jr. Member
  • **
  • Posts: 78
Last time I tired to make a donation to you Reggie it would not work.  Where do I make one?

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
THanks Reggie.  Anyway to send that error to the user when they are checking out?

If you have the module configured to "report errors on the front end" the user should see a nice big error message with all the details.

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Last time I tired to make a donation to you Reggie it would not work.  Where do I make one?

You can send it via paypal to my listed email address.  I don't want to post it directly here (spam bots will pick it up) but you should be able to get it from the "email" item on the left hand menu, or from my website.  It should also be in the uspsv5 README file =)
Thanks!
Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Nathan

  • Jr. Member
  • **
  • Posts: 78
I am having this same problem again.  Why does this happen so often?  I wish a message was sent to me when a customer is having trouble.  Any log files where I can see if anyone abandon a shopping cart because they were having problems?  Here is what I am getting:

Please select a Shipping Method!
Debug: Starting Shipping module: uspsv5
Debug: uspsv5::__construct() - Starting module version 5.2011.02.10
Debug: uspsv5::list_rates() - Starting
Debug: Shipment::addPackage() Adding a new bundled package
Debug: Shipment::addPackage() - Package Number: 1
Debug: Shipment::addPackage() - Package is Bundled
Debug: Shipment::addPackage() - Maxweight: 70
Debug: Package::addItem() - ***** Adding item 23 (Nojmuk Skin Salve) to package #1 *****
Debug: Package::addItem() - Package weight is now: 0.274125 LBS
Debug: Package::addItem() - WARNING - product dimensions assumed to be INCHES
Debug: Package::addItem() - ***** Adding item 26 (Minagin Salve) to package #1 *****
Debug: Package::addItem() - Package weight is now: 0.529125 LBS
Debug: Package::addItem() - WARNING - product dimensions assumed to be INCHES
Debug: Package::addItem() - ***** Adding item 28 (Nojmak Lip Balm) to package #1 *****
Debug: Package::addItem() - Package weight is now: 0.5386875 LBS
Debug: Package::addItem() - WARNING - product dimensions assumed to be INCHES
Debug: Package::addItem() - ***** Adding item 8 (Ginee Lip Balm) to package #1 *****
Debug: Package::addItem() - Package weight is now: 0.54825 LBS
Debug: Package::addItem() - WARNING - product dimensions assumed to be INCHES
Debug: Package::query_rates() - Querying for Source: US/49770 , Destination: US/54884, Weight: 0.54825, Value: 44
Debug: uspsv5::get_rates_array() - Calculating domestic shipping.
Debug: XML Post:
http://Production.ShippingAPIs.com/ShippingAPI.dll?API=RateV4&XML=<RateV4Request USERID="DDDDDDD" ><Revision /><Package ID="0"><Service>All</Service><ZipOrigination>49770</ZipOrigination><ZipDestination>54884</ZipDestination><Pounds>0</Pounds><Ounces>9</Ounces><Container /><Size>REGULAR</Size><Machinable>FALSE</Machinable></Package></RateV4Request>
XML Result:
<?xml version="1.0"?><br /> <RateV4Response><Package ID="0"><Error><Number>-2147219401</Number><Source>;clsRateV4.CreateAllPostage-;RateEngineV4.ProcessRequest</Source><Description> Error Information: The Destination ZIP Code you have entered is invalid.</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package></RateV4Response><br />

    Shipper   Shipping Rate   Price
   DHL   World_1 > 4kg   $41.66
   DHL   World_2 > 4kg   $50.53
Debug: Package::query_rates() - Rate query returned null results.
Debug: Shipment::populate() - query_rates() failed.
Debug: uspsv5::list_rates() - shipment->populate() failed!
Notice: We are unable to ship via USPS at this time. System Error.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Quote
Error Information: The Destination ZIP Code you have entered is invalid

Verify that the user's ZIP is valid.  If it is, then you'll need to take this issue up with USPS.
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Nathan

  • Jr. Member
  • **
  • Posts: 78
Ok thanks you.

Nathan

  • Jr. Member
  • **
  • Posts: 78
lowmips, it appear this problem only happens every now and then.  It sounds to me similar to this issue:
http://forum.virtuemart.net/index.php?topic=79072.0

The latest user had a correct 5 digit USA  zip code, but it does appear they added a period after the city name.   Would this cause the shipping error problem?

I would really like to drill down and see what this problem really is.  It seems 4 out of 7 of my last orders did not complete their order.   I suspect this shipping problem is the reason.  Not sure if it's entering incorrect data on the customer part of specifically a shipping error.

I would like to see an error sent to customer.  Like only use a 5 digit zip code (my understanding if they use a 9 digit zip code it will not work).  Or for USA customers, if they enter in a letter, it says only use numeric numbers.    If they have a . after their city name, it should flag it and tell the customer.

Always, on any error page it should give them the option to call on the phone and provide a number.

Can you please help me resolve this?

I am using VirtueMart 1.1.9 (Check for latest version)

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
The API does not consider the city name...only the country, state, and zip.

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)