Author Topic: HACK: AutoGen Metadata Metatag. Product, Category. Title, Description, Keywords  (Read 403190 times)

jeffrps

  • Beginner
  • *
  • Posts: 20
Hi,

Question , I installed the hack and was impressed right off the bat! However I notice when I go to add products it's displayed differential now. For example: with the hack uninstalled and I go to add a product, the Categories displays in a box with a scroll bar and you have the option to click mulitple categories. However with the hack installed that is no longer there, it simply looks the same as if I'm trying to add a "Related Product" by typing in a box so it can search for the categorie. Is this normal? Or Did I do something incorrectly? I hope this is fixable simply because I use the same Sub Categories under different Main Categories.

Thanks

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
That should not have changed at all. What VM version did you install it on?

jeffrps

  • Beginner
  • *
  • Posts: 20
1.1.6 .. You know though I never did run the sql file. Could that be the issue?
I'm thinking of upgrading to 1.1.8 .. is that a good idea?

Thanks

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
That surely did not help. You need to run that file.

jeffrps

  • Beginner
  • *
  • Posts: 20
Ok I will do that. Is it safe to upgrade or will it no work with the new version?

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Well, always make a backup. I have not personally tested on anything higher than 1.1.4, but I have seen on this thread others using successfully on updated versions.

If you are concerned about it, I have clearly commented where the hacks begin and end for all overwritten files. You should be able to easily move this to a newer versions with a few minutes of copy and paste.

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
I have it running on 1.1.8


Just copied the code manually and inserted it

jeffrps

  • Beginner
  • *
  • Posts: 20
Ok so I updated to 1.1.8 , I copied each file into it's appropriate directory and ran the sql file. Still having the same issue, I've attached a photo so you can maybe better understand my issue. Last time I just replaced the php files with the orginal ones and it went back to normal. Any help would be appreciated , thanks

In the photo you can see the MetaData tab , that all seems to be working great! However it's the categories issue.. it's not showing all my main and sub categories which make it impossible to add products since I use some of the same sub categories under different main categories


*Update*
Ok so I put my backup php files back in and it's back to normal , here is a pic so you can see exactly what I'm talking about.



After looking and comparing the php file that has the hack included in it already and my backup ones... my backup ones has more data in it .. i'm not sure if i'm suppose to over write part of the data or what .. must be my newbness  :-\

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
you dont have to update product.productform   or the category form.

Those are almost never updated

jeffrps

  • Beginner
  • *
  • Posts: 20
If I don't update them then I can't see the metadata tab .. when I mean update I'm simply stating inserting the new php files that include the hack

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10431
  • VirtueMart Version: 3+
did you have the meta hack installed before updating to 1.1.8?

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Looking at your pic, I'd say I must have installed the search function instead of the regular category list. This means you can start typing the name of a category and search to have it bring back a list (yellow box to the right), of the matching categories. I probably did this because I was dealing with a long long list of categories.

This is just a guess. I have seen no one else complain about it, and I do not remember making it part of this release ever (if so it was a mistake), so it's still kinda fishy.

I recommend you do what I suggested previously. Keep default files, and copy over all hacks from the hacked file versions. Everything is commented with start and end tags.

jeffrps

  • Beginner
  • *
  • Posts: 20
did you have the meta hack installed before updating to 1.1.8?

Yes and no , yes I installed the php files but never ran the sql. I then replaced the php files with the defaults ones , updated to 1.1.8 then reinstalled php files and ran sql.

I'm going to try and manual enter the code into my default files as mine seems to have different coding. As you can tell I'm no programmer .. I greatly appreciate both of your help!

jeffrps

  • Beginner
  • *
  • Posts: 20
Update: Ok I manually entered the hack code into my default product.product_form and product.product_category_form php files and it all works great! My category listing is the way it normally is!! Very happy now! Thank you guys again for the help and for a great hack!!  ;D Now I just have to figure every option out , for now I'll let it do it's thing!

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
:) great! Good luck