Author Topic: When adding a new product the product type values are not saved.  (Read 3025 times)

RelativeDesign

  • Beginner
  • *
  • Posts: 3
    • Relative Design and Networking LLC
Hello,

In my configuration I have a product type called "application". When I go to add a new product I see an application tab for the product type. When I add a new product I'm able to click on the application product type tab and specify the parameter values.

However, upon clicking save the product is added but not the associated product type information. I have to re-open the newly added product, click "Add Product Type", save and then reset these values.

Thoughts?

Best Regards,
Jerret Kinsman
Relative Design and Networking LLC
Consulting, Engineering, Systems Management and Website Design
(503) 608-4650

ahmmog

  • Beginner
  • *
  • Posts: 3
Re: When adding a new product the product type values are not saved.
« Reply #1 on: April 21, 2011, 21:16:31 pm »
Hi,

I am facing them same issue with version 1.1.6

Any one has the solution?? dose it fixed in 1.1.8??

Thank you

biltong

  • Jr. Member
  • **
  • Posts: 125
    • Starfish Websites
Re: When adding a new product the product type values are not saved.
« Reply #2 on: July 25, 2011, 17:45:40 pm »
This problem occurs with newer versions of MySQL, which cause an error because there is a bug in VM 1.1.8 in file /administrator/components/com_virtuemart/classes/ps_product_type.php, line 129, change

Code: [Select]
$q .= ") TYPE=MyISAM;";
to

Code: [Select]
$q .= ") ENGINE=MyISAM;";
I have tested this with MySQL v 5.5.8 where the bug does occur and does not occur in MySQL v5.1.56

When you change the above code, it works with MySQL v 5.5.8

The bug has been reported to the development team.