Author Topic: ssl_error_rx_record_too_long Error on checkout  (Read 10034 times)

martinmarsian

  • Beginner
  • *
  • Posts: 2
ssl_error_rx_record_too_long Error on checkout
« on: August 13, 2008, 21:32:32 pm »
Hi. When trying to get to checkout, the browser gives me an error on SSL

ssl_error_rx_record_too_long

It worked before updating to 1.1.2, back then, when i set up my shop. But now its not working. VM 1.1.2 broke it?
Has someone an insight of why it is not working and what to do to avoid it?

Update: I installed a copy of xt commerce just to see what this will do. And it gives me the same error. Which means for me: Its either a client (me running Leopard on a Mac) or a Hosting Problem, a problem of my provider. Has anyone else experienced this?

Antity

  • Beginner
  • *
  • Posts: 1
Re: ssl_error_rx_record_too_long Error on checkout
« Reply #1 on: March 08, 2010, 22:56:59 pm »
Go into components > Virtuemart > Admin > Configuration

Go through the tabs and search for a SECUREURL the url on your should start with an https:// change that to http://

markitnow

  • Beginner
  • *
  • Posts: 3
Re: ssl_error_rx_record_too_long Error on checkout
« Reply #2 on: February 28, 2013, 20:12:26 pm »
Make sure "Enable SSL for sensitive areas (recommended)" is unchecked.

AndyLaw

  • Beginner
  • *
  • Posts: 4
Re: ssl_error_rx_record_too_long Error on checkout
« Reply #3 on: April 26, 2013, 15:19:41 pm »
Error code: ssl_error_rx_record_too_long

This usually means the implementation of SSL on your server is not correct. The error is usually caused by a server side problem which the server administrator will need to investigate.

Below are some things we recommend trying.

    Ensure that port 443 is open and enabled on your server. This is the standard port for https communications.

    If SSL is using a non-standard port then FireFox 3 can sometimes give this error. Ensure SSL is running on port 443.

    If using Apache2 check that you are using port 443 for SSL. This can be done by setting the ports.conf file as follows

    Listen 80
    Listen 443 https

    Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.