Author Topic: Latest joomla / Latest VM / product details not working on new products  (Read 1133 times)

maarten_cf

  • Beginner
  • *
  • Posts: 3
  • A beginner
When adding a new product, all is fine, but product details will not show. unless i disable SEF in joomla settings. then it works fine.

- tried template switch / no solution
- tried category change / no solution
- tried name change / no solution
- changed to default .htaccess file / no solution

when adding a new product, all new products do not show details view. Existing products work fine. in SEO i use -detail for detail view.

Can any one help me out where to find a solution for this problem? (VM 3.8.4 10335 / joomla 3.9.22 )

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10300
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Latest joomla / Latest VM / product details not working on new products
« Reply #1 on: October 28, 2020, 15:03:39 pm »
is your site multilingual? or non en-GB?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

maarten_cf

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Latest joomla / Latest VM / product details not working on new products
« Reply #2 on: October 28, 2020, 16:22:31 pm »
joomla has 2 languages, only one in use (NL)

maarten_cf

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Latest joomla / Latest VM / product details not working on new products
« Reply #3 on: October 28, 2020, 18:16:46 pm »
yes, it was a language thing. solved it by filling out the UK translation.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10300
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Latest joomla / Latest VM / product details not working on new products
« Reply #4 on: October 28, 2020, 22:48:50 pm »
if u need to fill the en-gb fields to show when on a single nl-nl site then your language setup isn't correct
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation