Author Topic: manufacturers not working  (Read 1808 times)

2cool

  • Jr. Member
  • **
  • Posts: 236
manufacturers not working
« on: February 12, 2020, 15:56:40 pm »
Hi, after update and migration (jmigrator) my multilanguage site the manufacturers links are not working anymore.

Get this error: 1146  Table 'newsite.#__virtuemart_product_custom_plg_customsforall' doesn't exist

This is on all manufactures links (modules/productpage/etc)
Also tried Prostar template but not working.

Joomla  3.9.15
Virtuemart 3.6.10 10211
PHP 7.3.1

I'm glad to hear any suggestion.

Regards,
Pas

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3640
  • using Matomo instead of Google Analytics
Re: manufacturers not working
« Reply #1 on: February 12, 2020, 16:03:42 pm »
The error message looks to me like you will need an update of the 'Custom Fields for All' plugin by breakdesigns, if you want to continue to use it.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9504
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: manufacturers not working
« Reply #2 on: February 12, 2020, 16:04:17 pm »
as #__virtuemart_product_custom_plg_customsforall is not a VM table
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

2cool

  • Jr. Member
  • **
  • Posts: 236
Re: manufacturers not working
« Reply #3 on: February 12, 2020, 16:07:31 pm »
Thanks,

Plugin is latest version already.

2cool

  • Jr. Member
  • **
  • Posts: 236
Re: manufacturers not working
« Reply #4 on: February 12, 2020, 16:10:19 pm »
hmmm....
Quote
as #__virtuemart_product_custom_plg_customsforall is not a VM table

Maybe this is did not migrate the right way.....how do you tell it's not ok? how can this be fixed?

Thanks,
Pas

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2604
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: manufacturers not working
« Reply #5 on: February 12, 2020, 22:33:52 pm »
Talk to the creater:
https://breakdesigns.net/extensions/joomla/custom-fields-for-all

Jörgen @ Kreativ Fotografi
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9504
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: manufacturers not working
« Reply #6 on: February 12, 2020, 22:50:56 pm »
look in your new DB .. is it there? Is it the same as the old DB? If not transfer it
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

pinochico

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 165
    • MiniJoomla
  • VirtueMart Version: 3
Re: manufacturers not working
« Reply #7 on: February 13, 2020, 06:57:40 am »
You must buy addon for Jmigrate for CustomField4all and first install this plugin on new version before start import from old website.
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

2cool

  • Jr. Member
  • **
  • Posts: 236
Re: manufacturers not working
« Reply #8 on: February 13, 2020, 10:18:16 am »
Thanks all,
Already contacted developer whose very helpfull looking for a solution.
Checking database, delete table and reinstall, not solved yet.
Maybe others had similar issues before and maybe knew a solution.
I have a addon for vm can't find 1 for customfields?

Regards,
Pas


 

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3640
  • using Matomo instead of Google Analytics
Re: manufacturers not working
« Reply #9 on: February 13, 2020, 15:45:44 pm »
How about using phpmyadmin to export/import that missing table? (Test with a copy of the site made from a backup first!)
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

2cool

  • Jr. Member
  • **
  • Posts: 236
Re: manufacturers not working
« Reply #10 on: February 13, 2020, 17:19:06 pm »
I noticed something weird.
In Virtuemart - tools: Install or if necessary update tables it shows this message:

created table newsitevirtuemart_manufacturers_da_dk
created table newsitevirtuemart_manufacturers_en_gb
created table newsitevirtuemart_manufacturers_nl_nl

Loooking at phpmyadmin I see this:
newsitevirtuemart_manufacturers_da_DK
newsitevirtuemart_manufacturers_en_GB
newsitexvirtuemart_manufacturers_nl_NL

Would this be a problem maybe?

Regards,
Pas

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9504
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: manufacturers not working
« Reply #11 on: February 13, 2020, 18:58:13 pm »
they definitely should be all lower case

delete the 3 newly created and rename the  da_DK etc
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation